[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: KDE vs. GNOME on F10



Adam Williamson wrote:
> It seems to happen rather a lot for that to be the case, though maybe
> the situation I'm most familiar with (KDE 4.0 -> 4.1 -> 4.2) is an
> unusual situation. I was watching KDE quite closely in MDV at that
> point, as quite a lot of features that people expected from 3.x were
> missing, and I remember, for instance, that someone was trying to get
> kmilo (for multimedia keys) working on 4.x, they had to port it to 4.0,
> then port it to 4.1, then to 4.2...

That's a plasmoid, the ABI for libplasma wasn't stable until 4.2. (It is 
now, so plasmoids built for 4.2 still work with 4.3.)

> as I said, I suppose this could just be because 4.0 didn't quite have
> everything settled down yet so some major changes still had to be made
> for 4.1 / 4.2. I'm not enough of an expert on KDE to be sure.

Right, Plasma still needed major changes there. The libraries used by 
regular applications kept binary compatibility though, an application built 
against 4.0 will still work with 4.3.

        Kevin Kofler



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]