[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: pygtk2 and its numpy dependency



Adam Jackson wrote:
On Mon, 2009-08-10 at 14:40 -0500, Jon Ciesla wrote:
Adam Jackson wrote:
a) remove the explicit Requires: numpy from pygtk2, require apps that
actually want this function to Require it themselves

b) fake the numpy data type ABI in pygtk2 itself by cult-and-pasting it
from numpy

c) declare that get_pixels_array() just doesn't work in Fedora
(historically true, back in like FC3)

d) leave things as they are

Since pygtk2 does actually use numpy, isn't d) the best (albeit most annoying) option?

Internally?  Or just to implement that one entrypoint?  I believe it to
be the latter.

- ajax
I'm not sure, but what practical difference would that make?

--
in your fear, seek only peace
in your fear, seek only love

-d. bowie


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]