[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

how to determain those no longer required packages



I'm reading APT and YUM source codes recently, and met the following
question:

for class apt.package.Package, there are a function "isAutoRemovable",
which means:
http://apt.alioth.debian.org/python-apt-doc/apt/package.html?highlight=isautoremovable#apt.package.Package.isAutoRemovable

Return True if the package is no longer required.
        
        If the package has been installed automatically as a dependency
        of another package, and if no packages depend on it anymore, the
        package is no longer required.


Do YUM codes have the same function as 'isAutoRemovable' feature??  or
how to determine such no longer required rpm packages using yum CLIs?


Thanks,
Ray



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]