[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rawhide and tagging requests



On Thu, 10 Dec 2009, Seth Vidal wrote:

On Thu, 10 Dec 2009, Jesse Keating wrote:

On Thu, 2009-12-10 at 10:56 +0200, Panu Matilainen wrote:
Hmm, looking at the traceback at the end of
http://kojipkgs.fedoraproject.org/mash/rawhide-20091209/logs/mash.log it's
not at all clear whether this is rpm-python bustage or yum... the
last
good compose (from 20091203) was before this went in:

* Thu Dec  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-2
- rebuild yum with latest HEAD patch
- add rpmdb caching patch james wrote to see if it breaks everyone :)

...and the rpmdb caching patch does touch the area where it's
crashing.
Can you try a compose with yum tagged down to 3.2.25-1 just to cut
down on
the moving parts involved?

Alternatively a reproducer that doesn't involve processing the entire
rawhide would be helpful :)



Yeah, it could totally be yum, I didn't do much investigation into it.
Just didn't have it in me as I'm stranded at an airport over night.

Looking at the rpmdb caching patch I'm not sure how it could be that. The parsing of local pkgs (what createrepo does) doesn't hit the rpmdb.

Yup, but this isn't createrepo crashing (the earlier one was):

2009-12-09 20:11:04 mash: createrepo: finished /mnt/koji/mash/rawhide-20091209/development/x86_64/os/ 2009-12-09 20:11:05 mash: Resolving multilib for arch x86_64 using method devel
2009-12-09 20:11:05 mash: Waiting for depsolve and createrepo to finish...
2009-12-09 20:21:28 mash: Resolving depenencies for arch x86_64
Traceback (most recent call last):
  File "/usr/bin/mash", line 96, in <module>
    main()
  File "/usr/bin/mash", line 84, in main
    rc = themash.doMultilib()
File "/usr/lib/python2.6/site-packages/mash/__init__.py", line 538, in doMultilib
    pid = self.doDepSolveAndMultilib(arch, repocache)
File "/usr/lib/python2.6/site-packages/mash/__init__.py", line 511, in doDepSolveAndMultilib
    (rc, errors) = yumbase.resolveDeps()
File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 718, in resolveDeps
    for po, dep in self._checkFileRequires():
File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 1012, in _checkFileRequires
    po = self.getInstalledPackageObject(pkgtup)
File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 2421, in getInstalledPackageObject raise Errors.RpmDBError, _('Package tuple %s could not be found in rpmdb') % str(pkgtup) yum.Errors.RpmDBError: Package tuple ('clamav-scanner-upstart', 'noarch', '0', '0.95.3', '1301.fc13') could not be found in rpmdb

	- Panu -


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]