[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

perl provides and requires from the same package



During the review for perl-NOCpulse-Object ( https://bugzilla.redhat.com/show_bug.cgi?id=485893 ) I have noticed that rpmbuild adds as requires some items which are provided by this very package (abreged version below):

[wolfy wolfy tmp]$ rpm -qp --provides
/home/wolfy/reports/perl-NOCpulse-Object/perl-NOCpulse-Object-1.26.9-1.fc11.noarch.rpm
perl(NOCpulse::AbstractObjectRepository)
perl(NOCpulse::BlockingDBMNamespace)
perl(NOCpulse::BlockingFileNamespace)
perl(NOCpulse::DBMObjectRepository)
perl(NOCpulse::INIObjectRepository)
perl(NOCpulse::MultiFileObjectRepository)
perl(NOCpulse::NSObject)
perl(NOCpulse::Namespace)
perl(NOCpulse::Object) = 1.26
perl(NOCpulse::ObjectProxy)
perl(NOCpulse::ObjectProxyServer)
perl(NOCpulse::PersistentObject)
perl(NOCpulse::SharedBlockingNamespace)
perl-NOCpulse-Object = 1.26.9-1.fc11

[wolfy wolfy tmp]$ rpm -qp --requires
/home/wolfy/reports/perl-NOCpulse-Object/perl-NOCpulse-Object-1.26.9-1.fc11.noarch.rpm
perl(NOCpulse::AbstractObjectRepository)
perl(NOCpulse::DBMObjectRepository)
perl(NOCpulse::Debug)
perl(NOCpulse::INIObjectRepository)
perl(NOCpulse::MultiFileObjectRepository)
perl(NOCpulse::Namespace)
perl(NOCpulse::Object)
perl(NOCpulse::SharedBlockingNamespace)


The packager thinks this is OK, I think that they should be filtered out. Could we have a second opinion, please ?

   Manuel


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]