[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: cpio MD5 sum mismatch when installing latest packages from koji



2009/2/25 Joshua C. <joshuacov googlemail com>:
> When trying to install some packages I got errors about mismatching MD5 sum:
>
>   1:libdrm                 ########################################### [ 20%]
> error: unpacking of archive failed on file
> /etc/udev/rules.d/91-drm-modeset.rules;49a5daec: cpio: MD5 sum
> mismatch
>   2:mesa-dri-drivers       ########################################### [ 40%]
> error: unpacking of archive failed on file
> /usr/lib64/dri/i915_dri.so;49a5daec: cpio: MD5 sum mismatch
>   3:mesa-libGL             ########################################### [ 60%]
> error: unpacking of archive failed on file
> /usr/lib64/libGL.so.1.2;49a5daec: cpio: MD5 sum mismatch
>   4:mesa-libGLU            ########################################### [ 80%]
> error: unpacking of archive failed on file
> /usr/lib64/libGLU.so.1.3.070300;49a5daec: cpio: MD5 sum mismatch
>   5:mesa-libOSMesa         ########################################### [100%]
> error: unpacking of archive failed on file
> /usr/lib64/libOSMesa.so.6.5.3;49a5daec: cpio: MD5 sum mismatch
>
> Has anyone gotten this? Is a result of the f11 mass rebuild? I also
> got this on the latest kernel-2.6.29-0.153.rc6.git2.fc11.x86_64
>
>   1:kernel-firmware        ########################################### [ 50%]
> error: unpacking of archive failed on file
> /lib/firmware/acenic/tg1.bin;49a5dba8: cpio: MD5 sum mismatch
>   2:kernel                 ########################################### [100%]
> error: unpacking of archive failed on file
> /boot/System.map-2.6.29-0.153.rc6.git2.fc11.x86_64;49a5dba8: cpio: MD5
> sum mismatch

I just saw the same thing when doing a mock build of a package for F111:

Error unpacking rpm package kernel-headers-2.6.29-0.148.rc6.fc11.x86_64
error: unpacking of archive failed on file
/usr/include/asm-generic/errno-base.h;49a5a30f: cpio: MD5 sum mismatch
Error unpacking rpm package bash-4.0-1.fc11.x86_64
error: unpacking of archive failed on file /bin/bash;49a5a30f: cpio:
MD5 sum mismatch
warning: %post(info-4.13a-1.fc11.x86_64) scriptlet failed, exit status 255
warning: %post(libsepol-2.0.35-1.fc11.x86_64) scriptlet failed, exit status 255
warning: %post(libselinux-2.0.77-5.fc11.x86_64) scriptlet failed, exit
status 255
Error unpacking rpm package popt-1.13-5.fc11.x86_64
error: unpacking of archive failed on file
/lib64/libpopt.so.0.0.0;49a5a30f: cpio: MD5 sum mismatch
Error unpacking rpm package audit-libs-1.7.12-1.fc11.x86_64
error: unpacking of archive failed on file
/etc/libaudit.conf;49a5a30f: cpio: MD5 sum mismatch
warning: %post(sed-4.1.5-11.fc11.x86_64) scriptlet failed, exit status 255
warning: %post(readline-5.2-13.fc9.x86_64) scriptlet failed, exit status 255
warning: %post(grep-2.5.3-3.fc11.x86_64) scriptlet failed, exit status 255
warning: %post(libidn-0.6.14-9.x86_64) scriptlet failed, exit status 255
warning: %post(nspr-4.7.3-3.fc11.x86_64) scriptlet failed, exit status 255
warning: %post(nss-3.12.2.0-4.fc10.x86_64) scriptlet failed, exit status 255
warning: %post(findutils-1:4.4.0-1.fc10.x86_64) scriptlet failed, exit
status 255
warning: %post(binutils-2.19.51.0.2-12.fc11.x86_64) scriptlet failed,
exit status 255
warning: %post(cpio-2.9.90-3.fc11.x86_64) scriptlet failed, exit status 255
warning: %post(diffutils-2.8.1-22.fc11.x86_64) scriptlet failed, exit status 255
warning: %post(cpp-4.4.0-0.21.x86_64) scriptlet failed, exit status 255
error: %pre(MAKEDEV-3.24-1.x86_64) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping MAKEDEV-3.24-1
warning: %post(iputils-20071127-6.fc10.x86_64) scriptlet failed, exit status 255
warning: %post(e2fsprogs-1.41.4-2.fc11.x86_64) scriptlet failed, exit status 255
warning: %post(net-tools-1.60-91.fc10.x86_64) scriptlet failed, exit status 255
warning: %post(libgomp-4.4.0-0.21.x86_64) scriptlet failed, exit status 255
Error unpacking rpm package procps-3.2.7-27.fc11.x86_64
error: unpacking of archive failed on file /bin/ps;49a5a30f: cpio: MD5
sum mismatch
Error unpacking rpm package ethtool-6-3.20090115git.fc11.x86_64
error: unpacking of archive failed on file /sbin/ethtool;49a5a30f:
cpio: MD5 sum mismatch
warning: %post(fedora-release-notes-10.0.0-1.noarch) scriptlet failed,
exit status 255
error: %pre(glibc-headers-2.9.90-7.x86_64) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping glibc-headers-2.9.90-7
warning: %post(glibc-devel-2.9.90-7.x86_64) scriptlet failed, exit status 255
warning: %post(gcc-4.4.0-0.21.x86_64) scriptlet failed, exit status 255
warning: %post(tar-2:1.21-1.fc11.x86_64) scriptlet failed, exit status 255
warning: %post(which-2.19-3.fc9.x86_64) scriptlet failed, exit status 255
warning: %post(make-1:3.81-14.fc10.x86_64) scriptlet failed, exit status 255
error: %pre(coreutils-7.0-7.fc11.x86_64) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping coreutils-7.0-7.fc11
warning: %post(pam-1.0.90-2.fc11.x86_64) scriptlet failed, exit status 255
warning: %post(util-linux-ng-2.14.2-3.fc11.x86_64) scriptlet failed,
exit status 255
warning: %post(gawk-3.1.6-4.fc11.x86_64) scriptlet failed, exit status 255
warning: %post(rsyslog-3.21.10-1.fc11.x86_64) scriptlet failed, exit status 255
warning: %post(cronie-1.2-5.fc11.x86_64) scriptlet failed, exit status 255
warning: %post(gzip-1.3.12-7.fc10.x86_64) scriptlet failed, exit status 255
warning: %post(module-init-tools-3.7-1.fc11.x86_64) scriptlet failed,
exit status 255
warning: %post(gamin-0.1.10-3.fc11.x86_64) scriptlet failed, exit status 255
error: %pre(initscripts-8.89-1.x86_64) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping initscripts-8.89-1
warning: %post(policycoreutils-2.0.62-2.fc11.x86_64) scriptlet failed,
exit status 255
error: %pre(udev-137-4.fc11.x86_64) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping udev-137-4.fc11
error: %pre(exim-4.69-9.fc11.x86_64) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping exim-4.69-9.fc11
warning: %posttrans(rpm-4.6.0-8.fc11.x86_64) scriptlet failed, exit status 255

Installed:
  bash.x86_64 0:4.0-1.fc11             bzip2.x86_64 0:1.0.5-3.fc10
  coreutils.x86_64 0:7.0-7.fc11        cpio.x86_64 0:2.9.90-3.fc11
  diffutils.x86_64 0:2.8.1-22.fc11     fedora-release.noarch 0:10.91-1
  findutils.x86_64 1:4.4.0-1.fc10      gawk.x86_64 0:3.1.6-4.fc11
  gcc.x86_64 0:4.4.0-0.21              gcc-c++.x86_64 0:4.4.0-0.21
  grep.x86_64 0:2.5.3-3.fc11           gzip.x86_64 0:1.3.12-7.fc10
  info.x86_64 0:4.13a-1.fc11           make.x86_64 1:3.81-14.fc10
  patch.x86_64 0:2.5.4-37.fc11         redhat-rpm-config.noarch 0:9.0.3-7.fc11
  rpm-build.x86_64 0:4.6.0-8.fc11      sed.x86_64 0:4.1.5-11.fc11
  shadow-utils.x86_64 2:4.1.2-11.fc11  tar.x86_64 2:1.21-1.fc11
  unzip.x86_64 0:5.52-9.fc9            util-linux-ng.x86_64 0:2.14.2-3.fc11
  which.x86_64 0:2.19-3.fc9

Dependency Installed:
  MAKEDEV.x86_64 0:3.24-1
  audit-libs.x86_64 0:1.7.12-1.fc11
  basesystem.noarch 0:10.0-1
  binutils.x86_64 0:2.19.51.0.2-12.fc11
  bzip2-libs.x86_64 0:1.0.5-3.fc10
  ca-certificates.noarch 0:2008-7
  checkpolicy.x86_64 0:2.0.16-3.fc10
  chkconfig.x86_64 0:1.3.41-1
  cpp.x86_64 0:4.4.0-0.21
  cracklib.x86_64 0:2.8.13-3
  cracklib-dicts.x86_64 0:2.8.13-3
  cronie.x86_64 0:1.2-5.fc11
  crontabs.noarch 0:1.10-28.fc11
  curl.x86_64 0:7.19.3-1.fc11
  cyrus-sasl-lib.x86_64 0:2.1.22-21.fc11
  db4.x86_64 0:4.7.25-9.fc11
  db4-utils.x86_64 0:4.7.25-9.fc11
  device-mapper.x86_64 0:1.02.30-1.fc11
  device-mapper-libs.x86_64 0:1.02.30-1.fc11
  e2fsprogs.x86_64 0:1.41.4-2.fc11
  e2fsprogs-libs.x86_64 0:1.41.4-2.fc11
  elfutils.x86_64 0:0.140-1.fc11
  elfutils-libelf.x86_64 0:0.140-1.fc11
  elfutils-libs.x86_64 0:0.140-1.fc11
  ethtool.x86_64 0:6-3.20090115git.fc11
  exim.x86_64 0:4.69-9.fc11
  fedora-release-notes.noarch 0:10.0.0-1
  file.x86_64 0:5.00-3.fc11
  file-libs.x86_64 0:5.00-3.fc11
  filesystem.x86_64 0:2.4.20-1.fc11
  gamin.x86_64 0:0.1.10-3.fc11
  gdbm.x86_64 0:1.8.0-29.fc10
  glib2.x86_64 0:2.19.8-1.fc11
  glibc.x86_64 0:2.9.90-7
  glibc-common.x86_64 0:2.9.90-7
  glibc-devel.x86_64 0:2.9.90-7
  glibc-headers.x86_64 0:2.9.90-7
  gmp.x86_64 0:4.2.4-4.fc11
  initscripts.x86_64 0:8.89-1
  iproute.x86_64 0:2.6.28-2.fc11
  iputils.x86_64 0:20071127-6.fc10
  kernel-headers.x86_64 0:2.6.29-0.148.rc6.fc11
  keyutils-libs.x86_64 0:1.2-3.fc9
  krb5-libs.x86_64 0:1.6.3-17.fc11
  less.x86_64 0:424-1.fc10
  libacl.x86_64 0:2.2.47-3.fc10
  libattr.x86_64 0:2.4.43-2.fc11
  libcap.x86_64 0:2.10-2.fc10
  libcurl.x86_64 0:7.19.3-1.fc11
  libgcc.x86_64 0:4.4.0-0.21
  libgomp.x86_64 0:4.4.0-0.21
  libidn.x86_64 0:0.6.14-9
  libselinux.x86_64 0:2.0.77-5.fc11
  libselinux-utils.x86_64 0:2.0.77-5.fc11
  libsemanage.x86_64 0:2.0.31-2.fc11
  libsepol.x86_64 0:2.0.35-1.fc11
  libssh2.x86_64 0:1.0-1.fc11
  libstdc++.x86_64 0:4.4.0-0.21
  libstdc++-devel.x86_64 0:4.4.0-0.21
  libvolume_id.x86_64 0:137-4.fc11
  linux-atm-libs.x86_64 0:2.5.0-5
  logrotate.x86_64 0:3.7.8-1.fc11
  lua.x86_64 0:5.1.4-1.fc10
  lzma.x86_64 0:4.32.7-1.fc10
  lzma-libs.x86_64 0:4.32.7-1.fc10
  mingetty.x86_64 0:1.08-2.fc9
  module-init-tools.x86_64 0:3.7-1.fc11
  mpfr.x86_64 0:2.4.0-1.fc11
  ncurses.x86_64 0:5.7-1.20090207.fc11
  ncurses-base.x86_64 0:5.7-1.20090207.fc11
  ncurses-libs.x86_64 0:5.7-1.20090207.fc11
  net-tools.x86_64 0:1.60-91.fc10
  nspr.x86_64 0:4.7.3-3.fc11
  nss.x86_64 0:3.12.2.0-4.fc10
  openldap.x86_64 0:2.4.14-1.fc11
  openssl.x86_64 0:0.9.8j-7.fc11
  pam.x86_64 0:1.0.90-2.fc11
  pcre.x86_64 0:7.8-1.fc10
  perl.x86_64 4:5.10.0-58.fc11
  perl-Module-Pluggable.x86_64 1:3.60-58.fc11
  perl-Pod-Escapes.x86_64 1:1.04-58.fc11
  perl-Pod-Simple.x86_64 1:3.07-58.fc11
  perl-libs.x86_64 4:5.10.0-58.fc11
  perl-version.x86_64 3:0.74-58.fc11
  pkgconfig.x86_64 1:0.23-7.fc11
  policycoreutils.x86_64 0:2.0.62-2.fc11
  popt.x86_64 0:1.13-5.fc11
  ppl.x86_64 0:0.10-8.fc11
  procps.x86_64 0:3.2.7-27.fc11
  psmisc.x86_64 0:22.6-8.fc10
  readline.x86_64 0:5.2-13.fc9
  rpm.x86_64 0:4.6.0-8.fc11
  rpm-libs.x86_64 0:4.6.0-8.fc11
  rsyslog.x86_64 0:3.21.10-1.fc11
  setup.noarch 0:2.7.7-4.fc11
  sqlite.x86_64 0:3.6.10-3.fc11
  sysvinit-tools.x86_64 0:2.86-26
  tcp_wrappers-libs.x86_64 0:7.6-53.fc10
  tzdata.noarch 0:2009a-1.fc11
  udev.x86_64 0:137-4.fc11
  upstart.x86_64 0:0.3.9-19.fc10
  ustr.x86_64 0:1.0.4-7.fc10
  zlib.x86_64 0:1.2.3-19.fc11


make: *** [mockbuild] Error 30


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]