[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Massive fallout from missing libssl.so.7 et al



On Sat, 17 Jan 2009 21:04:46 +0100, Kevin wrote:

> Tomas Mraz wrote:
> > Now this is really weird - it seems that there are the old scriptlets
> > from 0.9.8j-1.fc11 in the rpm database as well. How could that happen?
> 
> The postuninstall scriptlet from the old package is run during upgrades.
> (It's run AFTER the postinstall scriptlet of the new one. RPM installs the
> new package, then removes the old one. Of course only the files which are
> not in the new package are removed. But the postun scriptlet is run.)

You explain scriptlet ordering here, but Richard quoted the following:

| $ rpm -q openssl
| openssl-0.9.8j-3.fc11.x86_64

A single openssl package in the RPM database.

| # rpm -q --scripts openssl
| postinstall scriptlet (using /bin/sh):
| if [ "$(readlink /lib64/libcrypto.so.7)" != libcrypto.so.0.9.8j ] ; then
|     ln -sf libcrypto.so.0.9.8j /lib64/libcrypto.so.7 || :
| fi
| if [ "$(readlink /lib64/libssl.so.7)" != libssl.so.0.9.8j ] ; then
|     ln -sf libssl.so.0.9.8j /lib64/libssl.so.7 || :
| fi
| /sbin/ldconfig -X
| postuninstall scriptlet (using /bin/sh):
| /sbin/ldconfig -X
| postinstall scriptlet (using /bin/sh):
| /sbin/ldconfig -X
| postuninstall scriptlet (using /bin/sh):
| /sbin/ldconfig -X

Two postun and two post scriplets for a single package. There is no "old"
package until you give RPM a newer package for an upgrade transaction.
Here there should only be a single pair of postun/post scriptlets for
the installed 0.9.8j-3.fc11 pkg.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]