[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Explicit rpm requires



On Tue, Mar 10, 2009 at 03:53:24PM -0500, Rex Dieter wrote:
> OK, try something like this instead:
> 
> Requires: cfitsio = %(pkg-config --modversion cfitsio 2>/dev/null || echo 0) 

That seems to work.

To satisfy my curiosity (and understanding), why does that work, when
(at least when I run pkg-config locally) nothing gets spit out on
stderr?  

-- 
"Things should be made as simple as possible, but not any simpler. -- Einstein."
--------------------------
Matthew Truch
Department of Physics and Astronomy
University of Pennsylvania
matt truch net
http://matt.truch.net/

Attachment: pgpwNBHU3Kckc.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]