[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F10 -> rawhide update failure



Am Samstag, den 21.03.2009, 19:22 +0000 schrieb M A Young:
> On Fri, 20 Mar 2009, nodata wrote:
> 
> > Hello,
> >
> > I tried this:
> > yum update rpm
> > yum update --skip-broken
> >
> > but I get this:
> >
> > Transaction Check Error:
> >  package audit-libs-1.7.12-3.fc10.x86_64 (which is newer than
> > audit-libs-1.7.12-2.fc11.i586) is already installed
> >  file /etc/libaudit.conf from install of audit-libs-1.7.12-2.fc11.i586
> > conflicts with file from package audit-libs-1.7.12-3.fc10.x86_64
> 
> It looks like something strange is going on with audit-libs.i586 versus 
> audit-libs.x86_64. There is a temporary issue with F10 having a more 
> recent version of audit-libs than rawhide, but your problems might be 
> elsewhere and yum is trying to pull in audit-libs-1.7.12-2.fc11.i586 to 
> resolve a dependency problem.
> 
> > I can't do an rpm -e --nodeps audit-libs due to this:
> > # ldd $(which rpm) | grep "not found"
> > 	librpmbuild.so.0 => not found
> > 	librpm.so.0 => not found
> > 	librpmio.so.0 => not found
> 
> Another big question is how you have managed to update rpm without the 
> corresponding version of rpm-libs, which shouldn't be possible unless 
> something has gone wrong with yum, or you have done something strange, 
> such as trying to upgrade an x86_64 distribution from i586 rawhide.
> 
>  	Michael Young
> 

I am not doing anything strange. This was a simple enabled= change in
the yum config from a fresh F10 install with all updates :)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]