[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Qt 4.5 coming to Fedora 9 and 10, license changing to LGPL



Hi,

We are working on providing Qt 4.5.0 as updates for Fedora 9 and 10. The updates
have already been built. They will be tagged into the buildroots for Fedora 9
and 10 shortly after this announcement is sent, in order for KDE 4 packages to
get rebuilt against it, as some KDE modules are highly dependent on the Qt
version used to build them and check the Qt version at build time. (Therefore,
we timed the Qt upgrade to coincide with the KDE 4.2.2 update, which we will be
packaging during the next few days.) From there, the Qt 4.5.0 updates will be
pushed to updates-testing and eventually the stable updates together with
KDE 4.2.2.

If you maintain any Qt-4-based package, please:
* check if your package needs patching or rebuilding to fully work with Qt 4.5.
  The update is normally backwards-compatible, so almost all packages are
  expected to work with no changes. However, due to bugs in some applications
  and bugs in Qt 4.4 which were being worked around, there are some rare cases
  where patches are needed. If you are aware of any such patches, please apply
  them to Rawhide immediately if not already done, then to Fedora 9 and 10 as
  soon as Qt 4.5 is in the buildroots. Once you have the patched or rebuilt
  version built, please talk to us on #fedora-kde or the fedora-kde mailing list
  to have your package included into the Qt 4.5 update group.
* check if your package can benefit from getting rebuilt against Qt 4.5 for some
  other reason, e.g. new features which require Qt 4.5 at build time, or a new
  upstream version requiring Qt 4.5 to build. If so, please proceed as above.
* make sure you DO NOT push out an update which was built against Qt 4.5 before
  Qt 4.5 itself (as the compatibility is only unidirectional, i.e. packages
  built against Qt 4.5 will most likely NOT work with Qt 4.4). If you need to
  build and push an urgent update to a Qt-4-using package (e.g. a security
  update), please talk to Rex Dieter (via e-mail or IRC) to get Qt 4.5
  temporarily untagged from the buildroot so you can build it against Qt 4.4.

We are pushing this update to the stable releases of Fedora for 4 reasons:
* some packages benefit vastly from the improvements in Qt 4.5, in particular
  Arora hugely benefits from the major improvements in QtWebKit,
* it fixes several bugs in the Qt 4.4 series,
* it will be required for KDE 4.3 (and some other software) and
* at least one package in a third-party repository is waiting for the license
  change (see below) for license compatibility reasons.
As it is a backwards-compatible update, we do not expect major disruption.
Compatibility issues with Qt 4.5 have already been identified and fixed during
the weeks Qt 4.5 has been in Rawhide, so they should all be resolved by now.

Please also note that, as already announced when the new version hit Rawhide,
the license has changed from:
GPLv2 with exceptions or GPLv3 with exceptions
to:
LGPLv2 with exceptions or GPLv3 with exceptions
which is more permissive.

For the Fedora KDE SIG,
        Kevin Kofler


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]