[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

TeXLive 2009 autoprovides/autorequires



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Hi,

I upgraded to F12 recently and enabled the TeXLive 2009 
packages. One thing that the massive split has created is that 
package dependencies are not made at all. I had to manually 
install some packages to satisfy some dependencies. I created 
these (rudimentary) .prov and .req scripts (attached) to try and 
kickstart something.

As they are, they don't do versioning yet (seems that some 
packages do versioning with LaTeX commands) nor does it support 
\RequirePackage being split over multiple lines (similar with 
\ProvidesPackage). I also may not be handling all of the 
possibilities of where the provides and requires information may 
be in the files.

- --Ben
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iQIcBAEBCAAGBQJKyYICAAoJEKaxavVX4C1XnjgQAOuvMB9WMhtkzN7h+IjHcRu2
u4WFJRLVB4J/8zpPz/mxFbGIbeeJSjaUde+7oRuz2RV1jD9bC4P3sP4bRQN77Xrc
ffC1lOI1X6S3+AQt/nUonJnmG0/vqdeILWp/AulBNngpzb7w50Kj3iWGg+Zws5gy
tTDBCp9dZJNkXylqI6UNjduMghvI41p2md2l7cd1gzudmXvLWaZMDFBQ81OZJt1g
RE5JBi7+1OkNfINEjShKg+o/SlllZvT4u5erHWy7Fb/rOUGPX7qbj9ZqwZaQNWqU
Dpr/8TSrXmsiuKk7tr+jL+GAtdB+fx18ZDV4E3umvmqzG+0KzIj6WmuW/DEyotRs
qdqryzxSeZwtTjScBHAQG+TWlkm9X24hjnKnbyqIRvT81hawxPI/e6RAXTuuDUl8
R+53le3RG6/mMy7MDD6Aky1h37R+4uIpmNpIb7JaNHhtfRanROxUw1Ii1Fjh5d45
qA8i2pWaHPRC3OEMhaIgTFO1yHSWC5uLZ75K0owWKVQzo/UqFNAJwlGdIefM4YHD
mSGesiawXEMAK0Ggfy2YxcNYPfhErk6cy7vGS/TlQhouO6utJVkc/a4sjmZj7rlb
3EvpRn3M/YGqeWg9536I8L9ugVFDnEwq958DRznB0FKCVpycnph1zMofGviLkrVv
vjL/wtA8bfitn/xgR24o
=8Hkv
-----END PGP SIGNATURE-----

Attachment: texlive.prov
Description: application/shellscript

Attachment: texlive.req
Description: application/shellscript


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]