[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Howto handle multilib conflict?



On Fri, 2009-10-09 at 18:56 -0400, Neal Becker wrote:
> Just received:
> https://bugzilla.redhat.com/show_bug.cgi?id=528237
> 
> yum install libotf-devel.i586 libotf-devel.x86_64
> 
> yields:
> 
> Transaction Check Error:
>   file /usr/bin/libotf-config from install of libotf-devel-0.9.8-2.fc11.i586
> conflicts with file from package libotf-devel-0.9.8-2.fc11.x86_64
>   file /usr/share/doc/libotf-devel-0.9.8/example/Makefile from install of
> libotf-devel-0.9.8-2.fc11.i586 conflicts with file from package
> libotf-devel-0.9.8-2.fc11.x86_64
> 
> What is the recommended way to resolve this?

It's not to be considered a bug, AFAIK. We don't stipulate that
development packages be installable side-by-side in this way, we only
stipulate that for library packages where there's a need for it. There's
no particular use case where you absolutely need both -devel packages
installed at once.

-- 
Adam Williamson
Fedora QA Community Monkey
IRC: adamw | Fedora Talk: adamwill AT fedoraproject DOT org
http://www.happyassassin.net


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]