[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpms/libXres/devel .cvsignore, 1.9, 1.10 libXres.spec, 1.26, 1.27 sources, 1.10, 1.11



On Tue, Oct 13, 2009 at 01:21:38PM -0400, Adam Jackson wrote:
> 
> atropine:~% repoquery --whatprovides 'pkgconfig(xext)'
> libXext-devel-0:1.0.99.4-3.fc12.i686
> atropine:~% repoquery --requires libXext-devel | grep pkg
> pkgconfig
> pkgconfig(x11)
> pkgconfig(xextproto)
> 
> So, whatever.  Clearly the pkgconfig autorequires are doing the right
> thing: -devel packages that provide a .pc file pick up a Requires:
> pkgconfig.  The guidelines should be fixed.
> 
Agreed - do you have time to find out when the pkgconfig autoprovides went
into effect and put up a draft on the wiki?  Link it to:
https://fedoraproject.org/wiki/PackagingDrafts

If all Fedora releases have the autoprovides but EL-5 is still affected, the
draft can be as simple as: rpm detects pkgconfig dependencies in all Fedora
releases, please move the pkgconfig requires from [LINK] to the EPEL
specific guidelines.

Thanks,
-Tosiho

Attachment: pgpUdkZgZMaEk.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]