[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Major reorganization of TeX Live packages



Hi Jiri,

On Thu, Oct 22, 2009 at 08:46:29PM +0200, Jiri Cerny wrote:
> Hi Jindrich,
> 
> (sorry for not replaying to the original message, I was reading the
> list through archives)
> 
> I was using TeXLive 2009 repository before, without any problem. After
> seeing your message,
> I followed the instruction
> 
> > In case you have an older TL2009 installed on your system from the
> > testing repository, please consider removing it and installing again.
> 
> and after 'yum install texlive' I get  a lot of missing dependencies.

This is likely caused by the not up-to-date yum cache, please clean it
with "yum clean all" and try again.

> Installing texlive requires
> dvipdfm from the F12/rawhide repository, which requires kpathsea from
> the same repository and which in turn
> requires texlive-2007. Will it be fixed with texlive-2007-45 build?

Yes, it is fixed since texlive-2007-45 and on. Just upgrading the
kpathsea library itself to 2007-45 should suffice in most cases. You
can use packages from here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=137908

directly or by installing the new kpathsea via yum from updates-testing.
(You needn't to install the main TL2007 packages)

> Another, probably related issue: Why there is not a xdvi (and also
> dvipdfm) binary in the Texlive 2009 repository. Should one use the
> one from F12? This seems strange to me to have such mixture of 2007
> and 2009 versions.

It is intentional, because you can now use old applications (not yet
rebuilt against new kpathsea) together with TL2009. Up to now you
needed to remove all applications dependent on kpathsea because of its
dependency on TL2007 which is removed now.

> 
> Jiri
> 

Jindrich

-- 
Jindrich Novy <jnovy redhat com>   http://people.redhat.com/jnovy/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]