[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Publican question



Karsten 'quaid' Wade wrote:
On Tue, 2008-02-19 at 09:23 +1000, Jeff Fearn wrote:

Jared Smith wrote:
1) Do we want the toolchain to be able to detect the version of FOP and
adjust itself accordingly?
This is probably the best approach, however different versions of FOP require different configuration files and font metrics files. So we really want to keep the number of supported version to a low number, like say 2 :)

How about three+?  This is because we have Fedora N, Fedora N-1,
rawhide, and EPEL 5.  I'm reckoning that you might want to see the a
preferred version of fop in EPEL.  We'll continue to need it working in
the current, current-minus-one, and rawhide.

I came up with a way that can support an arbitrary number of config files :)

I have some patches in place to try and get FOP 0.94 working, however it's proving to be a pain to get working. Still plugging away on that.

Cheers, Jeff.

--
Jeff Fearn <jfearn redhat com>
Software Engineer
Engineering Operations
Red Hat, Inc


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]