[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Approval needed: cln, GiNaC



Tom 'spot' Callaway wrote:

On Wed, 2005-05-18 at 10:38 -0500, Quentin Spencer wrote:


These two packages are in CVS and need final approval. The cln library
is used by GiNaC. The best way to test these two packages is to build
them both and then run ginsh from the GiNaC-utils package.


...
Review of GiNaC:

...

Bad:

- Source does NOT match upstream:
096d076e58103149f05da0a8ecd03d67 GiNaC-1.3.0.tar.bz2 (upstream)
46bb82c40f3e00f8e7fe03708dfec2c9 GiNaC-1.3.0.tar.gz (cvs)
- Spec refers to .tar.gz which does not exist on upstream server,
only .tar.bz2 exists.


Fixed. I had originally adapted the spec file from one provided by the upstream maintainer, which continues to point to a file that doesn't exist his server!

- Refuses to build properly without: BuildRequires: readline-devel, tetex-latex, tetex-dvips
- Probably want to make sure that doxygen is present:
BuildRequires: doxygen


Added all of the above to BuildRequires.

- GiNaC 1.3.0 doesn't actually build in rawhide. The good news is that
GiNaC 1.3.1 does. You should move to that version.



Upgraded.

You'll need to fix these blockers before I can approve.


All of these should now be fixed.

regards,
Quentin


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]