[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: sqlite2 redux



On Sun, 2005-05-22 at 14:09 +0200, Michael Schwendt wrote:
> On Sat, 21 May 2005 21:39:40 -0400, Ignacio Vazquez-Abrams wrote:
> 
> > So now there's a way to install kannel, moodss, et al on FC4, which is
> > good. However, these packages will still interfere with upgrading from
> > FC3 to FC4, which is bad.
> 
> How do they interfere?

Through implicit requires kannel requires, e.g., libsqlite2.so.0. When
you upgrade from FC3 to FC4 it tries to replace the sqlite package,
removing this file and replacing it with, e.g., libsqlite3.so.0.
Obviously it *can't* remove the original package, so it can't install
the new one. This then cascades up through python-sqlite and then to
yum.

While yes, it will be solved by the first 'yum update' that happens
(assuming the maintainers get themselves in gear and switch to
sqlite2...), if this situation is avoidable with 10 minutes of work then
why even have the user encounter it at all?

-- 
Ignacio Vazquez-Abrams <ivazquez ivazquez net>
http://fedora.ivazquez.net/

gpg --keyserver hkp://subkeys.pgp.net --recv-key 38028b72

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]