[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Sponsor needed: Enlightenment DR17/E17+EFL



On Tuesday 24 May 2005 23:45, Matthew Miller wrote:
> On Tue, May 24, 2005 at 11:39:28AM -0400, Bill Nottingham wrote:
> > > The "engage" package shouldn't Requires: xine-lib-devel.  Just
> > > the BuildRequires.  You should Requires: xine-lib, though.
> >
> > ... and if you're requiring xine-lib, you really can't built it in
> > Extras.
>
> And even if you could, is there any reason to say "Requires:
> xine-lib" instead of just letting RPM's auto-deps pick it up?

Probably.  Anyway, in general, there's a lot of Requires: .*-devel in 
this repo.  So, that needs to be fixed by just using BuildRequires for 
all of them.

Also, *.a and *.la libs are in the non-devel packages.  So, these need 
to be filtered out into separate -devel packages.

Another one to look at is /usr/local shouldn't be used for these 
packages.  So, some configure fun needs to be engaged in for each of 
the packages that use this directory.

-- 
-jeff


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]