[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: non building packages list



On Wed, 2006-02-01 at 18:35 -0500, Jeremy Katz wrote:
> On Wed, 2006-02-01 at 15:19 -0800, Toshio Kuratomi wrote:
> > Yeah -- I added the X libraries that gnotime actually links against to
> > the BuildRequires but it looks like configure is bombing out because
> > it's searching for unnecessary X libraries.  AC_PATH_XTRA is the autconf
> > macro that's generating the check but without a little more info, about
> > what the check is failing to link against, I'm shooting in the dark.
> 
> Looking at /usr/share/autoconf/autoconf/libs.m4 (where AC_PATH_XTRA is
> defined), it seems that AC_PATH_XTRA looks for libICE and libSM, so
> adding libICE-devel and libSM-devel to the buildrequires should do it
> 
> Jeremy
> 
Yep.  That was my first thought::
[devel]$ grep libSM-devel gnotime.spec
  BuildRequires:  libSM-devel

[devel]$ repoquery --repoid=development --requires libSM-devel 
  libICE-devel
  libSM = 1.0.0-2
  xorg-x11-filesystem >= 0.99.2-3

So unless yum isn't picking up on the libSM-devel -> libICE-devel
dependency, this isn't the problem.... Hmm... From::
http://buildsys.fedoraproject.org/logs/fedora-development-extras/3430-gnotime-2.2.2-2.fc5/i386/root.log
[...]
  Install: libSM-devel.i386 0:1.0.0-2 - core
[...]
  Install: libICE-devel.i386 0:1.0.0-2 - core
[...]

So there's something else that's missing.

-Toshio

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]