[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Bug 170131] Review Request: php-extras - Additional PHP modules from the standard PHP distribution



Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

Summary: Review Request: php-extras - Additional PHP modules from the standard PHP distribution


https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=170131





------- Additional Comments From bugs michael gmx net  2006-02-27 08:41 EST -------
The "Requires: php = %{version}" in every module package is not good.
It causes upgrade problems between FC's "php" and every module package.
Querying the rpms, all contain just DSOs, no versioned paths, and
nothing obvious which would justify a dependency on a specific minor
version of PHP. In case you meant to use "Requires: php >= %{version}"
instead, then prefer that. Alternatively, drop the version completely,
since you know PHP in the FC repo is big enough.

RPATHs will need a close look to make sure they really never end up in
the binaries. With Rawhide they don't currently, but in the build log
they are still present, e.g.:
  -rpath /home/qa/tmp/rpm/BUILD/php-5.1.1/ext/dbase/modules 

-- 
Configure bugmail: https://bugzilla.redhat.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]