[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Troubleshooting yum and redhat 8.0



----- Original Message ----- 
From: "seth vidal" <skvidal phy duke edu>
To: "Discussion of the Fedora Legacy Project"
<fedora-legacy-list redhat com>
Sent: Monday, May 10, 2004 3:09 PM
Subject: Re: Troubleshooting yum and redhat 8.0


> On Mon, 2004-05-10 at 18:10, Eucke Warren wrote:
> > Ok, trying to stick with the RH8 build (for now).  I believe that I have
> > installed all of the required packages.  However, the install of Yum
fails
> > two dependencies.  They are as follows:
> >
> > D:  Requires: rpm-python >= 0:4.1.1                         NO
>
> Read carefully:
>
> rpm-python >= 0:4.1.1
>
> > [root email savedRPMs]# rpm -q rpm-python
> > rpm-python-4.1-1.06
>
> You have 0:4.1
>
> 4.1.1 is newer and it's in the utils/updates at fedora.us for rhl 8.0.
>
> -sv

Thank you.  I did attempt to install the required packages.  Reading the
logs more carefully, when I tried to install the 5 packages from the FL site
I found the following couple of entries (among many) in the install log:

D: ========== +++ rpm-4.1.1-1.8x
D:  Requires: libc.so.6(GLIBC_2.3.2)                        NO
D: package rpm-4.1.1-1.8x has unsatisfied Requires: libc.so.6(GLIBC_2.3.2)

D:  read h#     374 Header V3 DSA signature: NOKEY, key ID db42a60e
D: Conflicts: patch < 2.5

D: ========== --- rpm-python-4.1-1.06
D: closed   db index       /var/lib/rpm/Depends
error: Failed dependencies:
        libc.so.6(GLIBC_2.3.2) is needed by rpm-4.1.1-1.8x

D: ========== tsorting packages (order, #predecessors, #succesors, tree,
depth)
D:     0    0    8    0    0 +popt-1.7.1-1.8x
D:     1    1    7    0    1   +rpm-4.1.1-1.8x
D: ========== successors only (presentation order)
D:     2    0    0    1    0 -popt-1.7-1.06
D:     3    2    0    0    2     -rpm-4.1-1.06
D:     4    2    0    0    2     +rpm-build-4.1.1-1.8x
D:     5    2    0    0    2     -rpm-build-4.1-1.06
D:     6    2    0    0    2     +rpm-devel-4.1.1-1.8x
D:     7    2    0    0    2     -rpm-devel-4.1-1.06
D:     8    2    0    0    2     +rpm-python-4.1.1-1.8x
D:     9    2    0    0    2     -rpm-python-4.1-1.06
D: closed   db index       /var/lib/rpm/Pubkeys
D: closed   db index       /var/lib/rpm/Providename
D: closed   db index       /var/lib/rpm/Requirename
D: closed   db index       /var/lib/rpm/Basenames
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages

Checking to see if the needed package was there yielded
[root email temp]# rpm -q glibc
glibc-2.3.2-4.80.8

That, to me would seem to indicate that the needed package is there...it
must be something else that is failing the dependency check.  What am I
missing?  Thank you!

-Eucke




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]