[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Resolving deps for metacity updates



On Friday 12 September 2003 21.23, Aaron_Morales eogresources com wrote:
> I'm trying to install the 'metacity-2.4.55-6' or 'metacity-2.5.3-3' rpms on
> Red Hat 8.0 but they both have several dependancies:
>
>           error: Failed dependencies:
>           libXrandr.so.2 is needed by metacity-2.4.55-6
>           libstartup-notification-1.so.0 is needed by metacity-2.4.55-6
>           redhat-artwork >= 0.62 is needed by metacity-2.4.55-6

(All commands as root).

Get the src.rpm for metacity and run rpm -ivh on it. Open 
/usr/src/redhat/SPECS/metacity.spec and change Requires: redhat-artwork >= 
0.62 to Requires: redhat-artwork. Then run rpmbuild -bb 
/usr/src/redhat/SPECS/metacity.spec. When (if) it finishes, run 
rpm -Uvh /usr/src/redhat/RPMS/i386/metacity-2.5.3-3.i386.rpm. 

That _might_ work, but don't be suprised if it doesn't.

/Peter




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]