[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpm lockups - argh



On Mon, 22 Sep 2003, Sean Middleditch wrote:
> On Mon, 2003-09-22 at 10:46, rhllist assursys co uk wrote:
> > On Mon, 22 Sep 2003, Sean Middleditch wrote:
> > > On Mon, 2003-09-22 at 10:08, rhllist assursys co uk wrote:
> > > 
> > > > That only removes the problems of lockfiles (__*) being left lying around,
> > > > it doesn't solve the underlying problems of rpm hanging and subsequent
> > > > rpm database corruption.
> > > > 
> > > > The good news is, that for me at least, the backport of rpm available from
> > > > <http://www.rpm.org> works fine. As alluded to in the above Bugzilla report,
> > > > it's highly annoying that an official erratum hasn't been issued. :-C
> > > 
> > > The backport you mention are the files in 
> > > ftp://ftp.rpm.org/pub/rpm/test-4.1.1 ?
> > 
> > Yup, that's the badger. ;-)
> 
> Hmm, Rawhide has rpm 4.2.1-0.30, and the bug persists - I'm assuming I
> probably don't want to downgrade, since the 4.1.1 test is just
> backported stuff from 4.2, yes?

Put it this way; I'm running 4.1.1 on RH8 and it's trouble free, despite the
heavy use I make of RPM. I haven't tried 4.2.1, and I haven't tried using
RH9/Severn as a base platform either. On distros with NPTL-enabled kernels
(i.e. RH9+) it may also be well worth setting $LD_ASSUME_KERNEL=2.2.5 (e.g.
"LD_ASSUME_KERNEL=2.2.5 rpm -ivh foo-1.2.3-4.i386.rpm").

> > Best Regards,
> > Alex.

Best Regards,
Alex.




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]