[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: VMware server cannot run on FC6




On Oct 28, 2006, at 7:45 PM, ronald warsow wrote:

Dave Jones wrote:
On Sat, Oct 28, 2006 at 01:41:42PM -0700, alan wrote:

 > Nope.  Wrong answer.
> > Symlink config.h to autoconf.h in /usr/src/kernel/<version>/ include/linux.

Nope, wrong answer ;-)

Remove the #include <linux/config.h> from anything that "needs" it.

	Dave


may i give a completion ?

assuming  we talking about VMware-server-1.0.1-29996:

- under /usr/lib/vmware/modules/source is a file called "vmnet.tar"
- (saving and) extracting (tar -xf vmnet.tar) gives a directory called "vmnet-only"
- in this directory is a file called "procfs.c"
- at line 34 is the magical "#include <linux/config.h>" ( found with grep -snHRi "linux/config.h" vmnet-only )

- commenting this line with /* ... */
- tar'ing this ( tar -cf vmnet.tar vmnet-only)

that all, so far.

vmware-config.pl gives a warning about "blabla-smac-blabla", but runs...

okay ?

--
fedora-list mailing list
fedora-list redhat com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

After following your instructions step by step, the configuration script finally runs. What doesn't run is VMWare, if I try to launch it from the terminal, it says that it was not configured correctly and that I should run the configuration script once again.
EJ


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]