[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Error: Missing Dependency: libcucul.so.0()(64bit) is needed by package



I have the same problem on F9 64bit.  In my case the problem was vlc in your case it's mplayer and xine.  I removed vlc and the updates went fine. These packages have have not been rebuilt with the latest libcaca package.  All you can do is remove the mplaye and xine packages, do the update, and wait until the updated mplayer and xine packages become available.

Paolo

On Sat, May 9, 2009 at 6:21 PM, Rich Emberson <emberson rich gmail com> wrote:
Fedora 9
Yesterday and today I get while updating one of my machines:
Error: Missing Dependency: libcucul.so.0()(64bit) is needed by package


On 64bit machine without mplayer:
# yum update

Resolving Dependencies
--> Running transaction check
---> Package PyQt4.x86_64 0:4.4.4-6.fc9 set to be updated
---> Package PyQt4-devel.x86_64 0:4.4.4-6.fc9 set to be updated
---> Package elfutils.x86_64 0:0.141-1.fc9 set to be updated
---> Package elfutils-libelf.x86_64 0:0.141-1.fc9 set to be updated
---> Package elfutils-libelf-devel.x86_64 0:0.141-1.fc9 set to be updated
---> Package elfutils-libs.x86_64 0:0.141-1.fc9 set to be updated
---> Package kdegraphics.x86_64 7:4.2.2-5.fc9 set to be updated
--> Processing Dependency: kio_msits = 7:4.2.2-5.fc9 for package: kdegraphics
---> Package kdegraphics-libs.x86_64 7:4.2.2-5.fc9 set to be updated
---> Package lcms.x86_64 0:1.18-2.fc9 set to be updated
---> Package lcms-libs.x86_64 0:1.18-2.fc9 set to be updated
---> Package xine-lib.x86_64 0:1.1.16.3-2.fc9.1 set to be updated
---> Package xine-lib-pulseaudio.x86_64 0:1.1.16.3-2.fc9.1 set to be updated
--> Running transaction check
---> Package kio_msits.x86_64 7:4.2.2-5.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                  Arch      Version             Repository         Size
================================================================================
Updating:
 PyQt4                    x86_64    4.4.4-6.fc9         updates-newkey    3.3 M
 PyQt4-devel              x86_64    4.4.4-6.fc9         updates-newkey    6.6 M
 elfutils                 x86_64    0.141-1.fc9         updates-newkey    228 k
 elfutils-libelf          x86_64    0.141-1.fc9         updates-newkey     56 k
 elfutils-libelf-devel    x86_64    0.141-1.fc9         updates-newkey     26 k
 elfutils-libs            x86_64    0.141-1.fc9         updates-newkey    194 k
 kdegraphics              x86_64    7:4.2.2-5.fc9       updates-newkey    3.5 M
 kdegraphics-libs         x86_64    7:4.2.2-5.fc9       updates-newkey    933 k
 lcms                     x86_64    1.18-2.fc9          updates-newkey     82 k
 lcms-libs                x86_64    1.18-2.fc9          updates-newkey    109 k
 xine-lib                 x86_64    1.1.16.3-2.fc9.1    updates-newkey    2.4 M
 xine-lib-pulseaudio      x86_64    1.1.16.3-2.fc9.1    updates-newkey     17 k
Installing for dependencies:
 kio_msits                x86_64    7:4.2.2-5.fc9       updates-newkey     19 k

Transaction Summary
================================================================================
Install      1 Package(s)
Update      12 Package(s)
Remove       0 Package(s)

On 64bit machine with mplayer:
# yum update
Loaded plugins: refresh-packagekit
fedora                                                   | 2.4 kB     00:00
rpmfusion-free-updates                                   | 2.5 kB     00:00
rpmfusion-nonfree-updates                                | 2.5 kB     00:00
rpmfusion-free                                           |  951 B     00:00
adobe-linux-i386                                         |  951 B     00:00
updates-newkey                                           | 3.6 kB     00:00
rpmfusion-nonfree                                        |  951 B     00:00
updates                                                  | 2.6 kB     00:00
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package PyQt4.x86_64 0:4.4.4-6.fc9 set to be updated
---> Package PyQt4-devel.x86_64 0:4.4.4-6.fc9 set to be updated
---> Package elfutils.x86_64 0:0.141-1.fc9 set to be updated
---> Package elfutils-libelf.x86_64 0:0.141-1.fc9 set to be updated
---> Package elfutils-libelf-devel.x86_64 0:0.141-1.fc9 set to be updated
---> Package elfutils-libs.x86_64 0:0.141-1.fc9 set to be updated
---> Package kdegraphics.x86_64 7:4.2.2-5.fc9 set to be updated
--> Processing Dependency: kio_msits = 7:4.2.2-5.fc9 for package: kdegraphics
---> Package kdegraphics-libs.x86_64 7:4.2.2-5.fc9 set to be updated
---> Package lcms.x86_64 0:1.18-2.fc9 set to be updated
---> Package lcms-libs.x86_64 0:1.18-2.fc9 set to be updated
---> Package lcms-libs.i386 0:1.18-2.fc9 set to be updated
---> Package libcaca.x86_64 0:0.99-0.7.beta16.fc9 set to be updated
--> Processing Dependency: libcucul.so.0()(64bit) for package: mplayer
--> Processing Dependency: libcucul.so.0()(64bit) for package: xine
--> Processing Dependency: libcucul.so.0()(64bit) for package: mplayer-gui
---> Package xine-lib.x86_64 0:1.1.16.3-2.fc9.1 set to be updated
---> Package xine-lib-extras.x86_64 0:1.1.16.3-2.fc9.1 set to be updated
---> Package xine-lib-pulseaudio.x86_64 0:1.1.16.3-2.fc9.1 set to be updated
--> Running transaction check
---> Package kio_msits.x86_64 7:4.2.2-5.fc9 set to be updated
--> Processing Dependency: libcucul.so.0()(64bit) for package: mplayer
--> Processing Dependency: libcucul.so.0()(64bit) for package: xine
--> Processing Dependency: libcucul.so.0()(64bit) for package: mplayer-gui
--> Finished Dependency Resolution
mplayer-1.0-0.100.20090204svn.fc9.x86_64 from installed has depsolving problems
  --> Missing Dependency: libcucul.so.0()(64bit) is needed by package
mplayer-1.0-0.100.20090204svn.fc9.x86_64 (installed)
xine-0.99.5-4.fc9.x86_64 from installed has depsolving problems
  --> Missing Dependency: libcucul.so.0()(64bit) is needed by package
xine-0.99.5-4.fc9.x86_64 (installed)
mplayer-gui-1.0-0.100.20090204svn.fc9.x86_64 from installed has depsolving
problems
  --> Missing Dependency: libcucul.so.0()(64bit) is needed by package
mplayer-gui-1.0-0.100.20090204svn.fc9.x86_64 (installed)
Error: Missing Dependency: libcucul.so.0()(64bit) is needed by package
xine-0.99.5-4.fc9.x86_64 (installed)
Error: Missing Dependency: libcucul.so.0()(64bit) is needed by package
mplayer-1.0-0.100.20090204svn.fc9.x86_64 (installed)
Error: Missing Dependency: libcucul.so.0()(64bit) is needed by package
mplayer-gui-1.0-0.100.20090204svn.fc9.x86_64 (installed)


I watched the mailing list to see if anyone else was having this problem, but
so far its only me.

RME

--
fedora-list mailing list
fedora-list redhat com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]