[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Fedora-livecd-list] Traceback with newest yum



Hi.

With newest yum and yum-metadata-parser I got the following traceback
when starting livecd-creator:


> /usr/lib/python2.5/site-packages/pykickstart/parser.py:600:
> DeprecationWarning: Script does not end with %end.  This syntax has
> been deprecated.  It may be removed from future releases, which will
> result in a fatal error from kickstart.  Please modify your kickstart
> file to use this updated syntax. warnings.warn(_("%s does not end
> with %%end.  This syntax has been deprecated.  It may be removed from
> future releases, which will result in a fatal error from kickstart.
> Please modify your kickstart file to use this updated syntax.") %
> _("Script"), DeprecationWarning) mke2fs 1.40.2 (12-Jul-2007)
> Filesystem label=F8-KDE-17 OS type: Linux Block size=4096 (log=2)
> Fragment size=4096 (log=2) 524288 inodes, 1048576 blocks 10485 blocks
> (1.00%) reserved for the super user First data block=0 Maximum
> filesystem blocks=1073741824 32 block groups 32768 blocks per group,
> 32768 fragments per group 16384 inodes per group
> Superblock backups stored on blocks: 
>         32768, 98304, 163840, 229376, 294912, 819200, 884736
> 
> Writing inode tables: done                            
> Creating journal (32768 blocks): done
> Writing superblocks and filesystem accounting information: done
> 
> This filesystem will be automatically checked every 28 mounts or
> 180 days, whichever comes first.  Use tune2fs -c or -i to override.
> tune2fs 1.40.2 (12-Jul-2007)
> Setting maximal mount count to -1
> Setting interval between checks to 0 seconds
> No Repositories Available to Set Up
> No Repositories Available to Set Up
> No such package *debuginfo to remove
> Traceback (most recent call last):
>   File "/usr/bin/livecd-creator", line 1383, in <module>
>     sys.exit(main())
>   File "/usr/bin/livecd-creator", line 1361, in main
>     target.install()
>   File "/usr/bin/livecd-creator", line 858, in install
>     self.installPackages()
>   File "/usr/bin/livecd-creator", line 550, in installPackages
>     self.ayum.runInstall()
>   File "/usr/bin/livecd-creator", line 295, in runInstall
>     (res, resmsg) = self.buildTransaction()
>   File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 557,
> in buildTransaction (rescode, restring) = self.resolveDeps()
>   File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 701,
> in resolveDeps CheckDeps, checkremoves, checkinstalls, missing =
> self._resolveRequires(errors) File
> "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 781, in
> _resolveRequires (checkdep, missing, errormsgs) =
> self._processReq(po, dep) File
> "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 250, in
> _processReq CheckDeps, missingdep =
> self._requiringFromTransaction(po, requirement, errormsgs) File
> "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 496, in
> _requiringFromTransaction reqpkg = self.rpmdb.searchNevra(name=name,
> ver=version, rel=release)[0] IndexError: list index out of range


The latest rawhide version I got here locally is yum-3.2.2-3.fc8 and
yum-metadata-parser-1.1.0-2.fc7. With them all is working fine.

Is this a problem with livecd-tools? If so I will file a bug against it.

Sebastian

Attachment: signature.asc
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]