[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

devel package problem



Hello there,

I have the package katapult
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=196262

rpmlint asks me to put the static libraries in -devel, which I did.
Now I have katapult and katapult-devel

during installation, I fell on

root(i386)[0]$rpm -ivh katapult-*
error: Failed dependencies:
      libkatapult.so.0 is needed by katapult-0.3.1.3-1.i386
      libkatapultcatalog.so.0 is needed by katapult-0.3.1.3-1.i386
      libkatapultdisplay.so.0 is needed by katapult-0.3.1.3-1.i386

the katapult package needs
%{_libdir}/lib%{name}.so
%{_libdir}/lib%{name}catalog.so
%{_libdir}/lib%{name}display.so
to install


how can I ask katapult to pull katapult-devel as dependency ?


Chitlesh
--
http://clunixchit.blogspot.com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]