[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: faied update a module



On Wed, 2006-05-24 at 07:50 +0900, Shintaro Fujiwara wrote:
> I yum updated lately.
> I edited .te file and made apache.pp
> When I tried to update apache.pp
> 
> [root intrajp devel]# semodule -u apache.pp
> libsepol.class_copy_callback: apache: Modules may not yet declare new
> classes.
> libsemanage.semanage_link_sandbox: Link packages failed
> semodule:  Failed!
> 
> Why and how shoul I do ?

I got the same message last week when I tried installing a .pp file that
had been built against an older selinux-policy package.

Did you make the module on the same machine you're trying to install it
on?

Does "semodule -i apache.pp" give the same error?

Do you get the same error if you first remove the apache module?

Paul.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]