[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: xorg + nvidia = bad news



Followup to my own post :)

I switched back to kernel 2.6.1 (listed below) and the kudzu hangs.. but I
went interactive, skipped kudzu.. recompiled my kernel module for 2.6.1
and voila :) I am back to using my fancy closed source video driver..
looks like 2.6.3 is what made it unhappy, not xorg

HOWEVER! gdm is still fscked :)

tommy


On Tue, 23 Mar 2004 17:31:03 -0700, Tommy McNeely wrote:

> Well,
> 
> I finally trashed up2date.. the "some sort of I/O error occurred, not a
> gzip'd file" was getting really old.. yum, however, seems to work just
> fine (although it takes a fricken eternity to download the headers the
> first time). I followed the various people's steps to get xorg installed
> on FC2t1. it worked.. I even enabled the "ld.so.conf.d" stuff before I did
> xorg, and I didn't have to re-add the X11 lib path. I did, however have to
> add xfs back (chkconfig --add xfs).
> 
> Along with xorg, I updated approximately 300 other packages, so this may
> or may not have anything to do with xorg. Anyways, when I rebooted, I went
> through the normal re-compiling of the nvidia kernel module (I think
> "nvidia-installer -f -K") .. and when I did a "startx" it went to a black
> screen and just sat there.. couldn't even ping the box anymore.. so I
> reset.. and it hung again during RHGB.. so I turned that off and it hung
> when it tried to go to init 5... so I booted to the non-smp kernel (cause
> it wouldn't have the nvidia driver and would nicely fail).. and changed my
> XF86Config to use the "nv" driver... now X starts, but GDM is still hosed.
> I get a black screen with an "X" cursor.. if I move the mouse or touch the
> keyboard gdm crashes, and comes up to a blue screen saying stuff about how
> there is already an X server running.. bla bla bla.. X didn't crash.. its
> still there in F7 .. so.. I killed that off and ran startx manually .. and
> that seems to work.. ofcourse minus the login screen (gdm) and the dual
> head (TwinView) .. since I never logout, I could really care less about
> GDM, but if someone has a tip on getting nvidia to work, I would be
> greateful :)
> 
> [root cookies root]# rpm -qa | grep xorg
> xorg-x11-Mesa-libGLU-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-twm-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-75dpi-fonts-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-sdk-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-xauth-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-ISO8859-9-75dpi-fonts-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-devel-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-font-utils-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-base-fonts-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-ISO8859-2-75dpi-fonts-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-ISO8859-15-100dpi-fonts-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-tools-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-cyrillic-fonts-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-xdm-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-doc-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-Mesa-libGL-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-syriac-fonts-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-ISO8859-15-75dpi-fonts-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-ISO8859-14-75dpi-fonts-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-100dpi-fonts-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-ISO8859-2-100dpi-fonts-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-libs-data-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-xfs-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-ISO8859-14-100dpi-fonts-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-Xnest-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-libs-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-Xvfb-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-truetype-fonts-0.0.6.6-0.0.2004_03_11.6
> xorg-x11-ISO8859-9-100dpi-fonts-0.0.6.6-0.0.2004_03_11.6
> [root cookies root]# uname -a
> Linux cookies.central.sun.com 2.6.3-2.1.253.2.1 #1 Fri Mar 12 14:01:55 EST 2004 i686 athlon i386 GNU/Linux
> [root cookies root]# rpm -q kernel-smp
> kernel-smp-2.6.1-1.65
> kernel-smp-2.6.3-2.1.242
> kernel-smp-2.6.3-2.1.253
> kernel-smp-2.6.3-2.1.253.2.1
> [root cookies root]#
> 
> all updates as of (NOW) :)
> 
> 0000:01:05.0 VGA compatible controller: nVidia Corporation NV25 [GeForce4 Ti 4600] (rev a3) (prog-if 00 [VGA])
>         Subsystem: VISIONTEK: Unknown device 0037
>         Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 10
>         Memory at 52000000 (32-bit, non-prefetchable)
>         Memory at c0000000 (32-bit, prefetchable) [size=128M]
>         Memory at c8000000 (32-bit, prefetchable) [size=512K]
>         Capabilities: [60] Power Management version 2
>         Capabilities: [44] AGP version 2.0
> 
> NVIDIA-Linux-x86-1.0-5336-pkg1.run
> 
> 
> 
> Thanks in advance,
> Tommy




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]