[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Installation of FC T2: GRUB interactive on1st installandGRUBhang on 2nd install



Hi,

I tried EVERYTHING from grub-install, to interactive grub
so something is very wrong and I am unable to understand
it.  The grub.conf file is correct, the MBR is written
on the same drive as the /boot (although / is on a different
drive, non-active parition) so I have no idea what the problem
is.  Heck, I have installed RH MANY times with no problems,
so why is FCT2 failing for me?

Any ideas???

Thanks,
Dan

-----Original Message-----
From: Kenny Speer [mailto:kenny speer comcast net]
Sent: Sunday, May 02, 2004 5:11 PM
To: For testers of Fedora Core development releases
Subject: Re: Installation of FC T2: GRUB interactive on1st
installandGRUBhang on 2nd install


Try 'man grub'

And then run grub-install and select the root part and then re-install 
grub.  My guess is that you selected to use the first sector of the boot

partition instead of the MBR.

~kenny

Daniel B. Thurman wrote:

>Hi,
>
>Oh wow... that would imply that I would have to manually
>scrub the hda drive and reinstall? I did previously had
>RH9 on it and when I installed the FCT2, I did a new 
>install on it...  you would think that the FC should
>have partitioned, reformatted, and installed a new
>MBR ???
>
>Is there a way to force a reinstall of the MBR using
>grub in linux rescue to be sure so that I can save
>2+ hours of reinstall?
>
>Thanks,
>Dan
>
>-----Original Message-----
>From: Chris Kloiber [mailto:ckloiber ckloiber com]
>Sent: Sunday, May 02, 2004 5:00 PM
>To: For testers of Fedora Core development releases
>Subject: RE: Installation of FC T2: GRUB interactive on 1st
>installandGRUBhang on 2nd install
>
>
>On Mon, 2004-05-03 at 07:57, Daniel B. Thurman wrote:
>  
>
>>Hi all,
>>
>>I did a little more researching but nothing gave me any
>>clues to what is going on and why GRUB hangs...  I inserted
>>CD1 and ran linux rescue and found:
>>
>>My drives and partitions are:
>>/dev/hda1	/boot  (active)
>>/dev/hdb3	/
>>
>>/etc/grub.conf
>># grub.conf generated by anaconda
>>#
>># ... blah, blah...
>>#boot=/dev/hda1
>>default=0
>>timeout=10
>>splashimage=(hd0,0)/grub/splash.xpm.gz
>>title Fedora Core (2.6.3-2.1.253.2.1)
>>	root (hd0,0)
>>	kernel /vmlinuz-2.6.3-2.1.253.2.1 ro root=LABEL=/ rhgb
>>	initrd /initrd-2.6.3-2.1.253.2.1.img
>>
>>The above configuration file is correct, so... why
>>is GRUB hanging when starting up?
>>
>>All I get on a boot up is all the usual pc bootup text,
>>then after that a cleared screen with a black background
>>and 4 characters in white:
>>
>>GRUB[]
>>
>>where [] is the block-cursor.
>>
>>Best regards,
>>Dan
>>    
>>
>
>#boot=/dev/hda1
>
>I would guess that you have an older grub installed in /dev/hda that
>does not know where your current system is installed. So it's never
>getting as far as the grub in /dev/hda1.
>
>  
>


-- 
fedora-test-list mailing list
fedora-test-list redhat com
To unsubscribe: 
http://www.redhat.com/mailman/listinfo/fedora-test-list



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]