[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

yum still doesn't work correctly on x86_64



Just to let you know, the earlier problem I, and others, reported on x86_64 
with yum are still present.

For example:
yum -c yum.conf update
Gathering header information file(s) from server(s)
Server: Fedora Core 1.91 - x86_64 - Base
Server: development
Finding updated packages
Downloading needed headers
Resolving dependencies
.....Unable to satisfy dependencies
Package samba needs samba-common = 0:3.0.2a, this is not available.
Package xorg-x11-libs needs xorg-x11-libs-data = 0.0.6.6-0.0.2004_03_11.9, 
this is not available.
Package glibc needs glibc-common = 2.3.3-18, this is not available.

The packages it is complaining about are ones that have both i386 and x86_64 
versions.  I'm sure that's not a coincidence.

If I screw around with rpm --erase --justdb enought, I can satisfy yum and it 
will preform the update.  BTW, rpm --erase --justdb isn't documented!

Clearly, yum is confused by the multiple packages.

Interestingly, if I erase enought stuff, yum will go ahead and do the update, 
and will replace all the stuff I erased in the process.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]