[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: kernel 2.6.5-1.356 hangs at boot time



Sanjeev Das wrote:
Hi all,

I recently built kernel 2.6.5-1.356 from arjanv at
http://people.redhat.com/arjanv/2.6/RPMS.kernel/. The system fails to boot and hangs in runlevel 5 at "checking for new hardware"


what could be the problem? thanks for the help.

Sanjeev



For me, the problem was caused by my "Sandisk ImageMate 6 in 1" flash card reader. I had to disable kudzu in runlevel 1, then run the below command to get runlevel 5 or 3 to boot past the checking hardware prompt.


chkconfig --level 5 kudzu off

After I figured out it was my card reader, I disconnected the card reader and changed it back to normal with the below.

chkconfig --level 5 kudzu on

I don't know if this problem is related to the multilun parameter that was added to the kernel or not, to be able to read several different cards at once, in the card reader. I just know that it was hard to figure out.

To figure out the problem. I tried to run fdisk -l and found out that fdisk was hanging and would not list my disks. It hung on my usb hard disk and on the card reader.

I first removed the usb disk. The same lockup on checking hardware occurred. I then removed the card reader and rebooted. It rebooted and fdisk showed my disks (usb hard disk and other IDE drives).

I haven't put the card reader back on to confirm that the card rader was the actual problem. The amber light on the top of the reader worked. The green light for the CF flash was not lighted.


Good luck! Check for a usb device problem.


Jim



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]