[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Latest kernel don't boot with 4KSTACKS not set



Looks like the Hotmail web interface I used has stripped the blanks from the beginning of the context lines - the ones without a '+' or a '-'. Reinsert the blanks (one on each line should suffice) and hopefully everything will be OK. Alternatively, make your own patch - the patch is only adding three lines.

By "after the 4g4g.patch", I mean applying the '4g4g' patch as normal, *not* reversing it.

I get a malformed patch error on the line:

#define ARCH_MIN_TASKALIGN 16


Also, when you say after the 4g4g.patch, do you mean after reversing that
patch?

-Quasar

On Mon, 10 May 2004, Mike McEwan wrote:


Found the problem. It would appear that the '4g4g.patch' has also had some
CONFIG_4KSTACKS stuff removed recently. I applied the following and
everything is fine once more.

Make sure it's applied *after* the '4g4g.patch':

--- include/asm-i386/processor.h.orig	2004-05-09 23:50:05.000000000 +0100
+++ include/asm-i386/processor.h	2004-05-10 23:27:37.835866624 +0100
@@ -408,11 +408,11 @@

#define ARCH_MIN_TASKALIGN 16

-
+#ifdef CONFIG_4KSTACKS
#define STACK_PAGE_COUNT	(4096/PAGE_SIZE)
-
-
-
+#else
+#define STACK_PAGE_COUNT	(8192/PAGE_SIZE)	/* THREAD_SIZE/PAGE_SIZE */
+#endif

struct thread_struct {
/* cached TLS descriptors. */


_________________________________________________________________ Express yourself with cool new emoticons http://www.msn.co.uk/specials/myemo



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]