[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC2 install failure with selinux turned on....(Workaround)



OK. I fixed this: The problem appears that my home directory
(created by 'firstboot') was not correctly labelled.

'fixfiles relabel' seems to have fixed this.

I'm not sure if the fault lies with firstboot or with the
fact that I allocated a partion for /home.

If you run into this situation, reboot single-user and
run 'fixfiles relabel'.

tom

[I'll check bugzilla for anything telltale.]


-----------------------------------------------------------

    * From: Tom London <tom london comcast net>
    * To: fedora-test-list redhat com
    * Subject: FC2 install failure with selinux turned on....
    * Date: Thu, 20 May 2004 15:10:20 -0700

I did a fresh SELinux (and 'everything') installation of FC2 (wiping
clean
a previously working copy of FC2T3).  That is, I entered 'selinux' at
the installation/boot prompt.


I repartitioned and formatted the drive into /boot, /, /home (all
ext3)
and swap partitons.


I selected 'install everything', and the install and 'firstboot'
appears
to have worked properly.  I specified a new user (tbl), NTP etc. when
propted.


When the system 'came up' and I logged in as my 'normal' user, I got
the following error popup:
     Your home directory is listed as:
          '/home/tbl'
     but it does not appear to exist. Do you want to log in with the
     / (root) directory as your home directory?


     It is unlikely anything will work unless you use a failsafe
session.


So, something didn't setup quite right.  (I'll boot single user and
see
if the directory got created and labeled incorrectly)


It then return to the login screen, where I tried to login as root.
This
time I got the following:
    The Applet "gnome-settings-daemon" has quit
unexpectedly.  You can
     inform .....".


Clicking the 'inform developers' button has not no apparent effect.

Anyone see this/have hints?

   tom
-- 
___________________________________________________________
Sign-up for Ads Free at Mail.com
http://promo.mail.com/adsfreejump.htm



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]