[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum error-- no key



On Thu, 2004-10-28 at 11:53 -0500, Adam Yates wrote:
> can someone tell me what I need to do in order to fix this?
> thanks!
> ~Adam
> ----------------------------------------------
> [root lptp ~]# yum -y update
> Setting up Update Process
> Setting up Repo:  testing
> repomd.xml                100% |=========================| 1.1 kB    00:00
> Reading repository metadata in from local files
> testing   : ################################################## 2622/2622
> Resolving Dependencies
> --> Populating transaction set with selected packages. Please wait.
> ---> Package kernel.i686 0:2.6.9-1.643 set to be installed
> ---> Package gcc-c++.i386 0:3.4.2-6.fc3 set to be updated
> ---> Package gcc-java.i386 0:3.4.2-6.fc3 set to be updated
> ---> Package libstdc++.i386 0:3.4.2-6.fc3 set to be updated
> ---> Package gtk2.i386 0:2.4.13-3 set to be updated
> ---> Package libgcc.i386 0:3.4.2-6.fc3 set to be updated
> ---> Package comps.i386 1:3-0.20041026 set to be updated
> ---> Package system-config-securitylevel-tui.i386 0:1.4.14-1 set to be 
> updated
> ---> Package gcc.i386 0:3.4.2-6.fc3 set to be updated
> ---> Package system-config-securitylevel.i386 0:1.4.14-1 set to be updated
> ---> Package selinux-policy-targeted.noarch 0:1.17.30-2.11 set to be 
> updated
> ---> Package libgcj.i386 0:3.4.2-6.fc3 set to be updated
> ---> Package gcc-g77.i386 0:3.4.2-6.fc3 set to be updated
> ---> Package redhat-menus.noarch 0:1.13-1 set to be updated
> ---> Package libgcj-devel.i386 0:3.4.2-6.fc3 set to be updated
> ---> Package hal-cups-utils.i386 0:0.5.2-8 set to be updated
> ---> Package libf2c.i386 0:3.4.2-6.fc3 set to be updated
> ---> Package gtk2-devel.i386 0:2.4.13-3 set to be updated
> ---> Package cpp.i386 0:3.4.2-6.fc3 set to be updated
> ---> Package libstdc++-devel.i386 0:3.4.2-6.fc3 set to be updated
> ---> Package desktop-printing.i386 0:0.17-3 set to be updated
> --> Running transaction check
> 
> Dependencies Resolved
> Transaction Listing:
>  Install: kernel.i686 0:2.6.9-1.643
>  Update: comps.i386 1:3-0.20041026
>  Update: cpp.i386 0:3.4.2-6.fc3
>  Update: desktop-printing.i386 0:0.17-3
>  Update: gcc.i386 0:3.4.2-6.fc3
>  Update: gcc-c++.i386 0:3.4.2-6.fc3
>  Update: gcc-g77.i386 0:3.4.2-6.fc3
>  Update: gcc-java.i386 0:3.4.2-6.fc3
>  Update: gtk2.i386 0:2.4.13-3
>  Update: gtk2-devel.i386 0:2.4.13-3
>  Update: hal-cups-utils.i386 0:0.5.2-8
>  Update: libf2c.i386 0:3.4.2-6.fc3
>  Update: libgcc.i386 0:3.4.2-6.fc3
>  Update: libgcj.i386 0:3.4.2-6.fc3
>  Update: libgcj-devel.i386 0:3.4.2-6.fc3
>  Update: libstdc++.i386 0:3.4.2-6.fc3
>  Update: libstdc++-devel.i386 0:3.4.2-6.fc3
>  Update: redhat-menus.noarch 0:1.13-1
>  Update: selinux-policy-targeted.noarch 0:1.17.30-2.11
>  Update: system-config-securitylevel.i386 0:1.4.14-1
>  Update: system-config-securitylevel-tui.i386 0:1.4.14-1
> Downloading Packages:
> warning: rpmts_HdrFromFdno: V3 DSA signature: NOKEY, key ID 4f2a6fd2
> public key not available for 
> //var/cache/yum/testing/packages/gcc-c++-3.4.2-6.fc3.i386.rpm
> public key not available for 
> //var/cache/yum/testing/packages/gcc-java-3.4.2-6.fc3.i386.rpm
> public key not available for 
> //var/cache/yum/testing/packages/libstdc++-3.4.2-6.fc3.i386.rpm
> public key not available for 
> //var/cache/yum/testing/packages/gtk2-2.4.13-3.i386.rpm
> public key not available for 
> //var/cache/yum/testing/packages/libgcc-3.4.2-6.fc3.i386.rpm
> public key not available for //var/cache/yum/testing/packages/comps.rpm
> public key not available for 
> //var/cache/yum/testing/packages/system-config-securitylevel-tui-1.4.14-1.i386.rpm 
> 
> public key not available for 
> //var/cache/yum/testing/packages/gcc-3.4.2-6.fc3.i386.rpm
> public key not available for 
> //var/cache/yum/testing/packages/system-config-securitylevel-1.4.14-1.i386.rpm 
> 
> public key not available for 
> //var/cache/yum/testing/packages/selinux-policy-targeted-1.17.30-2.11.noarch.rpm 
> 
> public key not available for 
> //var/cache/yum/testing/packages/libgcj-3.4.2-6.fc3.i386.rpm
> public key not available for 
> //var/cache/yum/testing/packages/gcc-g77-3.4.2-6.fc3.i386.rpm
> public key not available for 
> //var/cache/yum/testing/packages/redhat-menus-1.13-1.noarch.rpm
> public key not available for 
> //var/cache/yum/testing/packages/libgcj-devel-3.4.2-6.fc3.i386.rpm
> public key not available for 
> //var/cache/yum/testing/packages/hal-cups-utils-0.5.2-8.i386.rpm
> public key not available for 
> //var/cache/yum/testing/packages/libf2c-3.4.2-6.fc3.i386.rpm
> public key not available for 
> //var/cache/yum/testing/packages/gtk2-devel-2.4.13-3.i386.rpm
> public key not available for 
> //var/cache/yum/testing/packages/cpp-3.4.2-6.fc3.i386.rpm
> public key not available for 
> //var/cache/yum/testing/packages/libstdc++-devel-3.4.2-6.fc3.i386.rpm
> public key not available for 
> //var/cache/yum/testing/packages/desktop-printing-0.17-3.i386.rpm
> public key not available for 
> //var/cache/yum/testing/packages/kernel-2.6.9-1.643.i686.rpm
> 
> 
You need to install the GPG keys.

the below should install the ones you need

rpm --import /usr/share/rhn/RPM-GPG-KEY
rpm --import /usr/share/rhn/RPM-GPG-KEY-fedora

-- 
Douglas Furlong
Systems Administrator
Firebox.com
T: 0870 420 4475        F: 0870 220 2178

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]