[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Optional Dependent RPMs



On 7/19/05, Stephen J. Smoogen <smooge gmail com> wrote:
> Isnt the problem with this that firefox would need to know about
> flashblock and any other optional packages.. The best I could see is
> each of the optional packages putting in a
> 
> Requires: firefox = 1.0.4
> 
> to make sure they only are with their working version.

This would require the flaskblock developers and maintainers to be
able to read the future :->

why exactly is flashblock no longer operating? Did firefox upstream
change the api for plugins?  If thats the case, does firefox expose a
versioned api for plugins to check?  If that is the case, rpm could be
taught to check the exposed api version string and automatically set
provides and requires for firefox and plugins via a new macro.

-jef


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]