[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Eclipse broken?



Installed latest Fedora Eclipse and it won't start. Gives the following error:

/root/workspace/.metadata/.log:

!SESSION 2007-05-07 17:10:03.004 -----------------------------------------------
eclipse.buildId=M20070212-1330
java.fullversion=GNU libgcj 4.1.2 20070424 (Red Hat 4.1.2-11)
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64 -clean

!ENTRY org.eclipse.core.runtime 2007-05-07 17:10:04.307
!MESSAGE Product org.eclipse.platform.ide could not be found.

!ENTRY org.eclipse.osgi 4 0 2007-05-07 17:10:04.310
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.core.internal.runtime.PlatformActivator$1.run(org.eclipse.core.runtime_3.2.0.v20060603.jar.so) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(org.eclipse.osgi_3.2.2.R32x_v20070118.jar.so) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(org.eclipse.osgi_3.2.2.R32x_v20070118.jar.so) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(org.eclipse.osgi_3.2.2.R32x_v20070118.jar.so) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(org.eclipse.osgi_3.2.2.R32x_v20070118.jar.so)
  at java.lang.reflect.Method.invoke(libgcj.so.8rh)
  at org.eclipse.core.launcher.Main.invokeFramework(startup.jar.so)
  at org.eclipse.core.launcher.Main.basicRun(startup.jar.so)
  at org.eclipse.core.launcher.Main.run(startup.jar.so)
  at org.eclipse.core.launcher.Main.main(startup.jar.so)

!ENTRY org.eclipse.osgi 2 0 2007-05-07 17:10:04.384
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2007-05-07 17:10:04.384
!MESSAGE Bundle update plugins/org.eclipse.ui_3.2.1.M20061108.jar was not resolved.
!SUBENTRY 2 org.eclipse.ui 2 0 2007-05-07 17:10:04.384
!MESSAGE Missing required bundle org.eclipse.swt_[3.2.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2007-05-07 17:10:04.384
!MESSAGE Bundle update plugins/org.eclipse.jface_3.2.2.M20061214-1200.jar was not resolved.
!SUBENTRY 2 org.eclipse.jface 2 0 2007-05-07 17:10:04.384
!MESSAGE Missing required bundle org.eclipse.swt_[3.2.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2007-05-07 17:10:04.384
!MESSAGE Bundle update plugins/org.eclipse.ui.workbench_3.2.2.M20070119-0800.jar was not resolved.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2007-05-07 17:10:04.384
!MESSAGE Missing required bundle org.eclipse.swt_[3.2.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2007-05-07 17:10:04.384
!MESSAGE Bundle update plugins/org.eclipse.team.cvs.ssh2_3.2.1.M20061205.jar was not resolved.
!SUBENTRY 2 org.eclipse.team.cvs.ssh2 2 0 2007-05-07 17:10:04.384
!MESSAGE Missing required bundle org.eclipse.swt_[3.2.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2007-05-07 17:10:04.384
!MESSAGE Bundle update plugins/org.eclipse.jface.text_3.2.2.r322_v20070104.jar was not resolved.
!SUBENTRY 2 org.eclipse.jface.text 2 0 2007-05-07 17:10:04.384
!MESSAGE Missing required bundle org.eclipse.swt_[3.2.0,4.0.0).


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]