[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

DHCP issue w/F7T4 live cd/dvd



When I booted this CD in the live configuration, all was well (except the audio, but I'm not really worried about that right now). I then installed on an extra partition and it all installed fine (except for the audio) but now, I can't pull an IP and keep it any longer than a few seconds. When I tail -f /var/log/messages, here is what I see, over and over:

May 16 07:10:58 localhost NetworkManager: <info>  Activation (eth0) Stage 2 of 5 (Device Configure) scheduled...
May 16 07:10:58 localhost NetworkManager: <info>  Activation (eth0) Stage 1 of 5 (Device Prepare) complete.
May 16 07:10:58 localhost NetworkManager: <info>  Activation (eth0) Stage 2 of 5 (Device Configure) starting...
May 16 07:10:58 localhost NetworkManager: <info>  Activation (eth0) Stage 2 of 5 (Device Configure) successful.
May 16 07:10:58 localhost NetworkManager: <info>  Activation (eth0) Stage 3 of 5 (IP Configure Start) scheduled.
May 16 07:10:58 localhost NetworkManager: <info>  Activation (eth0) Stage 2 of 5 (Device Configure) complete.
May 16 07:10:58 localhost NetworkManager: <info>  Activation (eth0) Stage 3 of 5 (IP Configure Start) started...
May 16 07:10:59 localhost NetworkManager: <info>  Activation (eth0) Beginning DHCP transaction.
May 16 07:10:59 localhost NetworkManager: <info>  Activation (eth0) Stage 3 of 5 (IP Configure Start) complete.
May 16 07:10:59 localhost NetworkManager: <info>  DHCP daemon state is now 12 (successfully started) for interface eth0
May 16 07:10:59 localhost NetworkManager: <info>  DHCP daemon state is now 1 (starting) for interface eth0
May 16 07:10:59 localhost dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
May 16 07:10:59 localhost dhclient: DHCPOFFER from 10.5.1.1
May 16 07:10:59 localhost dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
May 16 07:10:59 localhost dhclient: DHCPACK from 10.5.1.1
May 16 07:10:59 localhost NetworkManager: <info>  DHCP daemon state is now 2 (bound) for interface eth0
May 16 07:10:59 localhost NetworkManager: <info>  Activation (eth0) Stage 4 of 5 (IP Configure Get) scheduled...
May 16 07:10:59 localhost NetworkManager: <info>  Activation (eth0) Stage 4 of 5 (IP Configure Get) started...
May 16 07:10:59 localhost dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth0 for sub-path eth0.dbus.get.subnet_mask
May 16 07:10:59 localhost NetworkManager: <WARN>  get_ip4_uint32s(): get_ip4_uint32s(): error calling 'subnet_mask', DHCP daemon returned error ' org.freedesktop.DBus.Error.UnknownMethod', message 'Method "subnet_mask" with signature "" on interface "com.redhat.dhcp.dbus.get" doesn't exist '.
May 16 07:10:59 localhost NetworkManager: <info>  Activation (eth0) failure scheduled...
May 16 07:10:59 localhost NetworkManager: <info>  Activation (eth0) failed.
May 16 07:10:59 localhost NetworkManager: <info>  Activation (eth0) Stage 4 of 5 (IP Configure Get) complete.
May 16 07:10:59 localhost NetworkManager: <info>  Deactivating device eth0.
May 16 07:10:59 localhost dhclient: bound to 10.250.0.8 -- renewal in 97412 seconds.
May 16 07:10:59 localhost dhclient: DHCPRELEASE on eth0 to 10.5.1.1 port 67
May 16 07:10:59 localhost dhclient: send_packet: Network is unreachable
May 16 07:10:59 localhost dhclient: send_packet: please consult README file regarding broadcast address.
May 16 07:11:00 localhost NetworkManager: <info>  SWITCH: no current connection, found better connection 'eth0'.
May 16 07:11:00 localhost NetworkManager: <info>  Will activate connection 'eth0'.
May 16 07:11:00 localhost NetworkManager: <info>  Device eth0 activation scheduled...

More info - possibly useless:

uname
Linux version 2.6.20-1.3104.fc7 (brewbuilder hs20-bc2-3 build redhat com) (gcc version 4.1.2 20070418 (Red Hat 4.1.2-10)) #1 SMP Sat Apr 21 22:02:46 EDT 2007

from dmesg
forcedeth.c: Reverse Engineered nForce ethernet driver. Version 0.60.

from Network manager
nVidia Corporation CK804 Ethernet Controller

from modules
forcedeth 58577 0 - Live 0xffffffff88165000

release
Fedora release 6.93 (Rawhide)

Obviously, the card is detected and utilized so it can't be a hardware or driver issue, right? I also have an Ubuntu 7.04 partition and a Windows XP partition that I boot and the hardware (including audio) all works fine in those OSs. Has anybody else seen this? I looked through Bugzilla but didn't see anything like this. What is really confusing is that eth0 is fine and works flawlessly when I boot from the CD but not after I installed the OS.

--
Casey Stamper
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]