[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: X restart while updating?



On Wed, 16 May 2007 22:41:52 -0400
Jim Cornette <fct-cornette insight rr com> wrote:

> Tom Horsley wrote:
> > Just ran yumex in my fc7t4 partition and while it was running the
> > transaction (not sure how far along it was), the X server
> > suddenly restarted. It may have actually gotten finished, because the
> > rpm database gives no indication of being scrogged, but this
> > is certainly behavior I never saw before. Has this happened to
> > anyone else?
> > 
> 
> Not recently but in the past. Usually extreme upgrades from one distro 
> level to another respawn X during some package update phase.
> 
> If you check your cache, there might be some packages in the cache. When 
> Yum exits abruptly, like with X respawning, yum does not finish but bails.
> 
> What does 'package-cleanup --problems' output?
> 
> Jim
> 

Doesn't look too bad, mostly things from livna which I may have busted
much earlier when I was screwing around with repos (fortunately I plan a
clean install when f7 is released, so this partition isn't all that
important :-).

[root zooty ~]# package-cleanup --problems
Setting up yum
Excluding Packages in global exclude list
Finished
Reading local RPM database
Processing all local requires
Missing dependencies:
Package dvdstyler requires mjpegtools
Package dvdstyler requires mpgtx
Package dvdstyler requires y4mscaler
Package transcode requires libmjpegutils-1.8.so.0()(64bit)
Package transcode requires libquicktime.so.0()(64bit)
Package dap-server-cgi requires dap-server = 3.7.1-4.fc7
Package gallery2-ffmpeg requires gallery2 = 2.1-0.24.svn20060817.fc6
Package authconfig-gtk requires authconfig = 5.3.13-3.fc7
Package streamdvd-gui requires perl(Tk)
Package streamdvd-gui requires perl(Tk)
Package streamdvd-gui requires perl(Tk::BrowseEntry)
Package streamdvd-gui requires perl(Tk::BrowseEntry)
Package streamdvd-gui requires perl(Tk::JPEG)
Package streamdvd-gui requires perl(Tk::JPEG)
Package streamdvd-gui requires perl(Tk::LabFrame)
Package streamdvd-gui requires perl(Tk::Photo)
Package streamdvd-gui requires perl(Tk::Photo)
Package xscreensaver requires xscreensaver-base = 1:5.02-1.fc7
Package ffmpeg-libs requires libgsm.so.1()(64bit)
Package glibc requires glibc-common = 2.5.90-21
Package avidemux requires libjs.so.1()(64bit)

In any case, yum seems to be working. I'm downloading another slew
of updates with yumex again (I'll see if the X server restarts
again :-).

Or maybe there is a problem, yumex just reported:

No package Matching glibc.i686 :-).

I'l play with it some and see how it goes. I can always just
abandon it till the reinstall.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]