[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: transaction checks error on updates fc7



On Wed, 16 May 2007 08:52:05 -0400 Jesse Keating wrote:
This is a case where you probably need to rpm -e --nodeps the esound.i386,
then update getting esound, esound-libs for x86_64, then install the
esound-libs.i386 package to re-satisfy the needs of things like wine.  Ugly,
I know.  We need a solution here.

My method seems cleaner...
BTW, I discovered today another x86_64 PC where I have the same
situation, as I didn't update since mid of may. Before updating I'm
available to check or try something, to see if it could be solved or
to help debug.
See below.

yum update ran some minutes ago gave:


Transaction Check Error:
 file /usr/share/man/man1/esd-config.1.gz from install of
esound-devel-0.2.38-1.fc7 conflicts with file from package
esound-0.2.36-3
 file /etc/esd.conf from install of esound-libs-0.2.38-1.fc7
conflicts with file from package esound-0.2.36-3
 file /etc/esd.conf from install of esound-libs-0.2.38-1.fc7
conflicts with file from package esound-0.2.36-3
 file /usr/lib/libesd.so.0 from install of esound-libs-0.2.38-1.fc7
conflicts with file from package esound-0.2.36-3
 file /usr/lib/libesddsp.so.0 from install of
esound-libs-0.2.38-1.fc7 conflicts with file from package
esound-0.2.36-3
 file /etc/gconf/schemas/metacity.schemas from install of
metacity-2.18.0-2.fc7 conflicts with file from package
metacity-2.16.5-1.fc6
 file /usr/share/gnome/wm-properties/metacity.desktop from install of
metacity-2.18.0-2.fc7 conflicts with file from package
metacity-2.16.5-1.fc6
 file /usr/share/man/man1/esd.1.gz from install of
esound-0.2.38-1.fc7 conflicts with file from package esound-0.2.36-3

Error Summary
-------------

[root pevit00 ~]#
[root pevit00 ~]# yum update esound-0.2.36-3
Loading "fastestmirror" plugin
Loading "installonlyn" plugin
Loading mirror speeds from cached hostfile
Setting up Update Process
livna-development         100% |=========================| 1.1 kB    00:00
extras-development        100% |=========================| 2.1 kB    00:00
development               100% |=========================| 1.1 kB    00:00
Could not find update match for esound-0.2.36-3
No Packages marked for Update/Obsoletion

[root pevit00 ~]# yum remove esound-0.2.36-3
Loading "fastestmirror" plugin
Loading "installonlyn" plugin
Loading mirror speeds from cached hostfile
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package esound.i386 1:0.2.36-3 set to be erased
---> Package esound.x86_64 1:0.2.36-3 set to be erased
--> Processing Dependency: libesd.so.0 for package: gnome-media
--> Processing Dependency: libesd.so.0 for package: wine-esd
--> Processing Dependency: libesd.so.0 for package: arts
--> Processing Dependency: libesd.so.0 for package: gnome-media
--> Processing Dependency: libesd.so.0 for package: libgnome
--> Processing Dependency: esound = 1:0.2.36-3 for package: esound-devel
--> Processing Dependency: libesd.so.0 for package: control-center
--> Processing Dependency: libesd.so.0 for package: arts
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package gnome-media.i386 0:2.18.0-3.fc7 set to be erased
---> Package control-center.i386 1:2.18.0-12.fc7 set to be erased
---> Package wine-esd.i386 0:0.9.36-1.fc7 set to be erased
---> Package esound-devel.x86_64 1:0.2.36-3 set to be erased
---> Package gnome-media.i386 0:2.16.1-2.fc6 set to be erased
---> Package libgnome.i386 0:2.18.0-4.fc7 set to be erased
---> Package arts.i386 8:1.5.6-0.1.fc6 set to be erased
---> Package arts.i386 8:1.5.6-2.fc7 set to be erased
--> Processing Dependency: libartsflow_idl.so.1 for package: kdelibs
--> Processing Dependency: libgnome-2.so.0 for package: gnome-utils
--> Processing Dependency: libgnome-2.so.0 for package: libgnomeui
--> Processing Dependency: libgnome-2.so.0 for package: libgnomekbd
--> Processing Dependency: libgnome-2.so.0 for package: gnome-panel
--> Processing Dependency: libgnome-2.so.0 for package: seamonkey
--> Processing Dependency: libgnome-2.so.0 for package: gtkhtml3
--> Processing Dependency: libgnome-2.so.0 for package: libbonoboui
--> Processing Dependency: libgnome-2.so.0 for package: evolution
--> Processing Dependency: wine-esd = 0.9.36-1.fc7 for package: wine
--> Processing Dependency: libartsflow_idl.so.1 for package: kdelibs
--> Processing Dependency: libgnome-2.so.0 for package: eel2
--> Processing Dependency: libgnome-2.so.0 for package: evolution-data-server
--> Processing Dependency: libgnome-2.so.0 for package: gnome-pilot
--> Processing Dependency: libgnome-2.so.0 for package: gnome-desktop
--> Processing Dependency: libgnome-2.so.0 for package: libgnome-devel
--> Processing Dependency: libgnome-2.so.0 for package: gnome-desktop
--> Processing Dependency: libgnome-2.so.0 for package: libbonoboui-devel
--> Processing Dependency: libgnome-2.so.0 for package: firefox
--> Processing Dependency: libgnome-2.so.0 for package: libgnomeui
--> Processing Dependency: libgnome-2.so.0 for package: nautilus-cd-burner
--> Processing Dependency: libgnome-2.so.0 for package: gtkhtml3
--> Processing Dependency: libgnome-2.so.0 for package: gnome-pilot
--> Processing Dependency: libgnome-2.so.0 for package: gnome-panel
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package kdelibs.i386 6:3.5.6-3.fc7 set to be erased
---> Package gnome-desktop.i386 0:2.16.3-1.fc6 set to be erased
---> Package libbonoboui-devel.i386 0:2.18.0-1.fc7 set to be erased
---> Package seamonkey.i386 0:1.1.1-2.fc7 set to be erased
---> Package kdelibs.i386 6:3.5.6-0.3.fc6 set to be erased
---> Package firefox.i386 0:2.0.0.3-4.fc7 set to be erased
---> Package gnome-panel.i386 0:2.18.0-9.fc7 set to be erased
---> Package libgnomeui.i386 0:2.16.0-4.fc6 set to be erased
---> Package libgnomeui.i386 0:2.18.1-2.fc7 set to be erased
---> Package libgnomekbd.i386 0:2.18.0-1.fc7 set to be erased
---> Package libbonoboui.i386 0:2.18.0-1.fc7 set to be erased
---> Package eel2.i386 0:2.18.0.1-3.fc7 set to be erased
---> Package gnome-pilot.i386 0:2.0.15-1.fc6 set to be erased
---> Package gtkhtml3.i386 0:3.14.1-1.fc7 set to be erased
---> Package wine.i386 0:0.9.36-1.fc7 set to be erased
---> Package gnome-utils.i386 1:2.18.0-1.fc7 set to be erased
---> Package libgnome-devel.i386 0:2.18.0-4.fc7 set to be erased
---> Package gnome-pilot.i386 0:2.0.15-5.fc7 set to be erased
---> Package gnome-desktop.i386 0:2.18.0-4.fc7 set to be erased
---> Package gtkhtml3.i386 0:3.12.3-1.fc6 set to be erased
---> Package evolution.i386 0:2.10.1-4.fc7 set to be erased
---> Package evolution-data-server.i386 0:1.10.1-1.fc7 set to be erased
---> Package gnome-panel.i386 0:2.16.3-2.fc6 set to be erased
---> Package nautilus-cd-burner.i386 0:2.18.0-2.fc7 set to be erased
--> Processing Dependency: kdelibs = 6:3.5.6-0.3.fc6 for package: kdelibs-devel
--> Processing Dependency: libgpilotdconduit.so.2 for package: gnome-pilot-devel
--> Processing Dependency: libgtkembedmoz.so for package: firefox-devel
--> Processing Dependency: libgnome-desktop-2.so.2 for package:
gnome-desktop-devel
--> Processing Dependency: libgtkembedmoz.so for package: devhelp
--> Processing Dependency: libegroupwise-1.2.so.13 for package:
evolution-data-server-devel
--> Processing Dependency: libeel-2.so.2 for package: eel2-devel
--> Processing Dependency: libpanel-applet-2.so.0 for package: gnome-panel-devel
--> Processing Dependency: libgnomeui-2.so.0 for package: libgnomeui-devel
--> Processing Dependency: libkdecore.so.4 for package: k9copy
--> Processing Dependency: libkdecore.so.4 for package: kdelibs-devel
--> Processing Dependency: libedata-cal-1.2.so.6 for package:
evolution-data-server-devel
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package firefox-devel.i386 0:2.0.0.3-4.fc7 set to be erased
---> Package kdelibs-devel.x86_64 6:3.5.6-0.3.fc6 set to be erased
---> Package gnome-panel-devel.i386 0:2.18.0-9.fc7 set to be erased
---> Package kdelibs-devel.i386 6:3.5.6-3.fc7 set to be erased
---> Package eel2-devel.i386 0:2.18.0.1-3.fc7 set to be erased
---> Package libgnomeui-devel.i386 0:2.18.1-2.fc7 set to be erased
---> Package k9copy.i386 0:1-1.0 set to be erased
---> Package evolution-data-server-devel.i386 0:1.8.3-4.fc6 set to be erased
---> Package evolution-data-server-devel.i386 0:1.10.1-1.fc7 set to be erased
---> Package gnome-pilot-devel.i386 0:2.0.15-5.fc7 set to be erased
---> Package gnome-desktop-devel.i386 0:2.18.0-4.fc7 set to be erased
---> Package devhelp.i386 0:0.13-5.fc7 set to be erased

Dependencies Resolved

=============================================================================
Package                 Arch       Version          Repository        Size
=============================================================================
Removing:
esound                  i386       1:0.2.36-3       installed         279 k
esound                  x86_64     1:0.2.36-3       installed         298 k
Removing for dependencies:
arts                    i386       8:1.5.6-0.1.fc6  installed         4.0 M
arts                    i386       8:1.5.6-2.fc7    installed         4.0 M
control-center          i386       1:2.18.0-12.fc7  installed         8.5 M
devhelp                 i386       0.13-5.fc7       installed         586 k
eel2                    i386       2.18.0.1-3.fc7   installed         1.1 M
eel2-devel              i386       2.18.0.1-3.fc7   installed         214 k
esound-devel            x86_64     1:0.2.36-3       installed          96 k
evolution               i386       2.10.1-4.fc7     installed          54 M
evolution-data-server   i386       1.10.1-1.fc7     installed          10 M
evolution-data-server-devel  i386       1.8.3-4.fc6      installed
    3.6 M
evolution-data-server-devel  i386       1.10.1-1.fc7     installed
    4.6 M
firefox                 i386       2.0.0.3-4.fc7    installed          39 M
firefox-devel           i386       2.0.0.3-4.fc7    installed          20 M
gnome-desktop           i386       2.16.3-1.fc6     installed         1.9 M
gnome-desktop           i386       2.18.0-4.fc7     installed         2.0 M
gnome-desktop-devel     i386       2.18.0-4.fc7     installed         184 k
gnome-media             i386       2.18.0-3.fc7     installed         5.5 M
gnome-media             i386       2.16.1-2.fc6     installed         5.2 M
gnome-panel             i386       2.18.0-9.fc7     installed          11 M
gnome-panel             i386       2.16.3-2.fc6     installed          10 M
gnome-panel-devel       i386       2.18.0-9.fc7     installed         172 k
gnome-pilot             i386       2.0.15-1.fc6     installed         1.9 M
gnome-pilot             i386       2.0.15-5.fc7     installed         1.9 M
gnome-pilot-devel       i386       2.0.15-5.fc7     installed         164 k
gnome-utils             i386       1:2.18.0-1.fc7   installed         9.9 M
gtkhtml3                i386       3.14.1-1.fc7     installed         2.8 M
gtkhtml3                i386       3.12.3-1.fc6     installed         2.8 M
k9copy                  i386       1-1.0            installed         2.2 M
kdelibs                 i386       6:3.5.6-3.fc7    installed          49 M
kdelibs                 i386       6:3.5.6-0.3.fc6  installed          49 M
kdelibs-devel           x86_64     6:3.5.6-0.3.fc6  installed         6.9 M
kdelibs-devel           i386       6:3.5.6-3.fc7    installed         6.8 M
libbonoboui             i386       2.18.0-1.fc7     installed         1.2 M
libbonoboui-devel       i386       2.18.0-1.fc7     installed         1.0 M
libgnome                i386       2.18.0-4.fc7     installed         3.7 M
libgnome-devel          i386       2.18.0-4.fc7     installed         524 k
libgnomekbd             i386       2.18.0-1.fc7     installed         194 k
libgnomeui              i386       2.16.0-4.fc6     installed         3.1 M
libgnomeui              i386       2.18.1-2.fc7     installed         3.2 M
libgnomeui-devel        i386       2.18.1-2.fc7     installed         2.5 M
nautilus-cd-burner      i386       2.18.0-2.fc7     installed         1.8 M
seamonkey               i386       1.1.1-2.fc7      installed          33 M
wine                    i386       0.9.36-1.fc7     installed          0.0
wine-esd                i386       0.9.36-1.fc7     installed          99 k

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove      46 Package(s)

Is this ok [y/N]:
Exiting on user Command
Complete!


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]