[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Selecting Secure Wi-Fi Network with Network Manager



Hi,

I've just installed F9B. During the install, you're prompted to configure your network interfaces, so I tried to set up my wireless NIC (Cisco Aironet PC4800). It wasn't clear what format the WEP key should be in (i.e. decimal, hex, hex prefixed by 0x..., case sensitivity for hex) so I typed 0x... and hopefully my correct WEP key and the SSID.

Now the installation is complete but I can't connect to my network. Network Manager shows the network but when I select it I immediately get "The network connection has been disconnected". The trouble is I can't see how to check the credentials I entered during setup. If I right-click on NM and select "Edit Connections..." I just have 5 empty tabs with the Add, Edit and Delete buttons disabled.

The salient /var/log/messages entries are below, it looks like my credentials are wrong to me? Surely it would make sense to prompt me if these are incorrect or is this set somewhere else. (If so, it's very unintuitive).

Thanks in advance for any help or advice,

Leon...

/var/log/messages says:

Mar 30 13:40:34 leon1 NetworkManager: <info>  User
request for activation of eth0.
Mar 30 13:40:34 leon1 NetworkManager: <info>
Activation (eth0) starting connection 'System
discovery (eth0)'
Mar 30 13:40:34 leon1 NetworkManager: <info>
Activation (eth0) Stage 1 of 5 (Device Prepare)
scheduled...
Mar 30 13:40:34 leon1 NetworkManager: <info>
Activation (eth0) Stage 1 of 5 (Device Prepare)
started...
Mar 30 13:40:34 leon1 NetworkManager: <info>
Activation (eth0) Stage 2 of 5 (Device Configure)
scheduled...
Mar 30 13:40:34 leon1 NetworkManager: <info>
Activation (eth0) Stage 1 of 5 (Device Prepare)
complete.
Mar 30 13:40:34 leon1 NetworkManager: <info>
Activation (eth0) Stage 2 of 5 (Device Configure)
starting...
Mar 30 13:40:34 leon1 NetworkManager: <info>
Activation (eth0/wireless): access point 'System
discovery (eth0)' has security, but secrets are
required.
Mar 30 13:40:34 leon1 NetworkManager: <info>
Activation (eth0) Stage 2 of 5 (Device Configure)
complete.
Mar 30 13:40:34 leon1 NetworkManager: <WARN>
get_secrets_cb(): Couldn't get connection secrets:
dbus-settings.c.115 - Secrets were found for setting
'802-11-wireless-security' but none were valid..
Mar 30 13:40:34 leon1 NetworkManager: <info>
Activation (eth0) failed for access point (discovery)
Mar 30 13:40:34 leon1 NetworkManager: <info>  Marking
connection 'System discovery (eth0)' invalid.
Mar 30 13:40:34 leon1 NetworkManager: <info>
Activation (eth0) failed.
Mar 30 13:40:34 leon1 NetworkManager: <info>
Deactivating device eth0.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]