[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Trying to build tightvnc for FC10 from FC11 src.rpm





dexter wrote:
2009/2/12 Robert Moskowitz <rgm htt-consult com>:
Well I got the src.rpm for fc11, and after running rpmbuild, I found a
number of dependencies I needed.  I installed those and tried again and not
too supprisingly the rebuild failed.

First it is telling me that both user and group mockbuild do not exist and
it is using root.

Is this a problem?  I am running from userid:  me


After these warnings, I get an Executing(%prep) and a number of info
messages, then after a line about 'patching file configure.ac' I get:

Hunk #1 FAILED at 29.
Hunk #2 succeeded at 53 (offset 2 lines).
Hunk #3 succeeded at 1213 (offset 10 lines).
Hunk #4 FAILED at 1892.
2 out of 4 hunks FAILED -- saving rejects to file configure.ac.rej
patching file hw/Makefile.am
Hunk #1 FAILED at 33.
1 out of 1 hunks FAILED -- saving rejects to file hw/Makefile.am.rej
patching file mi/miinitext.c
Hunk #1 FAILED at 272.
Hunk #2 FAILED at 478.
2 out of 2 hunks FAILED -- saving rejects to file mi/miinitext.c.rej
error: Bad exit status from /var/tmp/rpm-tmp.lr6xIj (%prep)

So what do I do to get this working?


Start by looking at the spec file here:
   patch -p1 --fuzz=0 < ../xserver16.patch
xserver 1.6 aint out for F10 so do:
   patch -p1 --fuzz=2 < ../xserver15.patch
The other patches should apply clean, investigate those that dont then rebase.
Dex,

Thanks for this help, but it is clear that I need a bit more skill with rpmbuild than I have...

For when I make this change to ~/rpmbuild/SPECS/tightvnc.spec, then from ~/rpmbuild/SRPMS I run 'rpmbuild --rebuild tightvnc.......src.rpm', I get the src.rpm unpacked, the .spec file overwritten and I am back where I am.

So what should be my current dir, and what rpmbuild command do I use? (I will add this to my journal of 'learning rpmbuilding').



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]