[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Circular dependency Rawhide glibc and glibc-common



On Fri, 20 Feb 2009 16:17:26 -0500, you wrote:

>On Fri, 2009-02-20 at 16:15 -0500, Gerald Henriksen wrote:
>> On Fri, 20 Feb 2009 11:47:34 -0800, you wrote:
>> 
>> >Update and yum update for 64 bit Rawhide both choke on
>> >this circular dependency.  Both files seem to exist but
>> >rpm can't install either even with --force
>> 
>> Check to see if you have both x64 and i386 versions of glibc
>> installed, on my system yum seemed unable to handle the move from
>> i386->i586 for the 32bit glibc.
>
>it did? Can you post the exact errors you had?

Yum failed because it claimed glibc required an older version of
glibc-common.  Yum was trying to update to newer 64bit version of
glibc and glibc-common, and as soon as I temporarily removed the 32bit
version of glibc Yum was happy to do the update.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]