[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: missing dependency python(abi) = 2.5 for package: ...



On 1/2/09, Fulko Hew <fulko hew gmail com> wrote:
> On Fri, Jan 2, 2009 at 6:40 PM, Greg <spowd bigpond com> wrote:
>> On 3/01/2009 10:13 AM, Fulko Hew wrote:
>>>
>>> On Fri, Jan 2, 2009 at 6:11 PM, Greg<spowd bigpond com>  wrote:
>>>
>>>>
>>>> On 3/01/2009 9:54 AM, Fulko Hew wrote:
>>>>
>>>>>
>>>>> I decided to enable rawhide on my test F10 system, and do a
>>>>> yum update.
>>>>>
>>>>> I get a lot of dependency failures like:
>>>>>
>>>>> setroubleshoot-2.0.12-3.fc10.noarch from installed has depsolving
>>>>> problems
>>>>>   -->   Missing Dependency: python(abi) = 2.5 is needed by package
>>>>> setroubleshoot-2.0.12-3.fc10.noarch (installed)
>>>>>
>>>>> Any suggestions?
>>>>>
>>>>> TIA
>>>>> Fulko
>>>>>
>>>>>
>>>>>
>>>>
>>>> why did you enable rawhide? this isnt a support channel. use the irc
>>>> channel
>>>> or fedoraforum
>>>>
>>>
>>> Sorry.  I thought fedora-test was for testing rawhide?  ;-(
>>>
>>>
>>
>> it is but your not giving much details of what you are actually testing?.
>> by
>> the looks of it you have fc10 rpms
>
> I thought I'd be testing F11 (as updated from F10 via rawhide.
>
>> from what i understand you were using fedora10 an installed Fedora11 from
>> enabling rawhide. correct method for testing Fedora11 is downloading the
>> boot.iso an installing fc11
>
> Oh!  I was led to believe from
>
> https://fedoraproject.org/wiki/Releases/Rawhide#To_update_to_rawhide_via_yum
>
> that I could move to Rawhide from F10
>
>> that way an testing it alongside fc10. you say
>> your getting a lot of deps but what exactly did you install from rawhide
>> repo?
>
> Technically, I didn't install anything from rawhide, I simply enabled the
> rawhide repo as per the URL above, and did 'yum update'.
>
>> if you can figure that one out im sure you'll fix it
>
> The trouble is that it is complaining about
> "Missing Dependency: python(abi) = 2.5"
> for a vast number of packages.  Yum updated the system
> to python 2.5.2 but that doesn't help me to understand what
> package??? "python(abi)" is?
> At first I thought it was an unusually named package, then I thought
> It was a version of python, but downgrading python didn't help either.
>
> It seems as thought the rawhide packages need python 2.5
> and I now have python 2.5.2 installed???
>
> So I'm at a loss to understand exactly what's missing/wrong.
>
> (My ultimate goal was to find out if KDE 4.2 was packaged for testing
> yet, and if so, did it now contain fixes for the missing functionality,
> that KDE 3.5 has, that I need/want in 4.x.)

Did you have F10 updates-testing enabled?
Either way, the EVR in rawhide might be lower. You can
remove/re-install the packages, try --skip-broken, and combinations
therein.

jerry

-- 
To be named later.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]