[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

crypto_LUKS mounts fail (rawhide)



I tried to "backup" my system to a crypt_LUKS partition on a USB drive.

This has been the way I've been backing up for quite some time.

This now fails with Rawhide:

[root tlondon packages]# mount /dev/sdc1 /mnt
mount: unknown filesystem type 'crypto_LUKS'
[root tlondon packages]#

I've tried booting older kernels, reverting device-mapper, lvm2 and
util-linux-ng packages to no avail.

[root tlondon packages]# fdisk /dev/sdc

The number of cylinders for this disk is set to 38913.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs
   (e.g., DOS FDISK, OS/2 FDISK)

Command (m for help): print

Disk /dev/sdc: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0005772c

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1               1       38913   312568641   83  Linux

Command (m for help): quit

[root tlondon packages]#


Anyone successfully mounting LUKS encrypted partitions with rawhide?

This a known issue?

I've BZ'ed this here: https://bugzilla.redhat.com/show_bug.cgi?id=506960

Help appreciated.

tom
-- 
Tom London


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]