[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: f10 marked packages (was: Volume applet for gnome?)



On Sun, May 24, 2009 at 12:29 PM, Michal Jaegermann <michal harddata com> wrote:
> On Sun, May 24, 2009 at 11:21:58AM -0600, Reid Rivenburgh wrote:
>>
>> Another potential problem I have is this:
>>
>> % rpm -qa | grep fc10 | wc -l
>> 136
>
> If you install 'yum-utils' then you will find there
> 'package-cleanup' utility.  The first check is
>
>    package-cleanup --problems
>
> If none are reported then your installation is self-consistent.
> The next one would be
>
>    package-cleanup --orphans
>
> If you will see some "orphans", i.e. packages not in F11
> repositories, then you may remove some or all of them.  Check for
> "problems" again once you did that.
>
> Assorted packages in F11 repos can be inherited from F10.  Quite
> often there is no need to recompile.

Thanks for the reminder about package-cleanup.  Unfortunately, I do
have problems.  Some I was able to easily resolve, but here's one
tricky one (of about 10 total):

Package qt-mysql-4.5.1-10.fc10.x86_64 requires libcrypto.so.7()(64bit)

I just checked a development mirror site and found this:

qt-mysql-4.5.0-14.fc11.x86_64.rpm

Is it possible that some of my pre-upgrade rpms (when I was using
F10's updates-testing, not rawhide) were newer versions than the F11
ones, and therefore they didn't get upgraded?  That's what these
versions seem to suggest.  I guess I can force install the F11
versions now and get things in order?

Thanks,
Reid


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]