[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Intel graphics users: send me your VBIOS



On Fri, 2009-09-18 at 14:45 -0400, Adam Jackson wrote:
> If you have a machine with an Intel graphics chip, I need your help.
> I'm trying to make LVDS connection detection actually reliable, and I
> think I have a solution that involves parsing BIOS data tables.  But I
> need more testcases to raise my confidence that it's actually a reliable
> method.
> 
> So, do this:
> 
> % sudo dd if=/dev/mem of=/tmp/rom bs=64k skip=12 count=1
> 
> and email me that rom file, along with a brief description of the
> machine, and in particular what graphics outputs (DVI, VGA, LVDS...) are
> _actually_ present on the machine.

Just as a clarification: the problem I'm trying to solve here is the
appearance of an LVDS output (from X's perspective) when there is not
one actually present.  So, ROMs from machines that have had a phantom
LVDS connector at some point in the past are especially valuable.  IIRC
the Mac Mini and Dell Studio compact machines have had this problem
before.

There's one particular field in the connector table for LVDS that seems
to be indicative of LVDS presence.  So far, for machines where LVDS
really is present, it's consistently non-zero (and these are very
common, since everybody buys laptops these days).  I'd like to find more
machines where LVDS is _not_ present to see if it's consistently zero
there; so far that seems to be the case, but I've only got two
samples...

- ajax

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]