[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [fedora-virt] Improving release / update process for virt packages



On Fri, 2009-04-17 at 15:46 -0400, Bill Davidsen wrote:
> Mark McLoughlin wrote:
> > On Mon, 2009-04-06 at 15:41 +0100, Daniel P. Berrange wrote:
> >
> >   
> >> So in summary
> >>
> >>  - All new upstream releases built in rawhide
> >>  - New upstream releases also built in stable preview branch if possible
> >>  - Only bugfixes built in stable updates/updates-testing branch
> >>  - In exceptional circumstances, rebase for preview branch can be
> >>    built to updates/updates-testing after alot of positive testing
> >>     
> >
> > Dan did a great job of laying out the process we intend using for
> > updates to virt packages going forward. Re-read it if you missed it the
> > first time:
> >
> >   http://www.redhat.com/archives/fedora-virt/2009-April/msg00008.html
> >
> > One thing we hadn't discussed until earlier this week is what to do
> > about current F9 and F10 updates.
> >
> > We had pushed libvirt 0.6.0 (late January) and 0.6.1 (early March) to F9
> > and F10 updates-testing. Neither of these were ever pushed to stable
> > updates.
> >
> > Packages aren't intended to live in updates-testing forever - it is
> > intended that a package gets pushed to stable after some testing, or
> > gets unpushed if its too unstable. If a package does linger in
> > updates-testing for too long, it prevents simple bugfix updates for the
> > previous version from being pushed in the mean time.
> >
> > Since we weren't confident that pushing 0.6.1 to F9 and F10 stable
> > updates, we were left with no choice but to unpush it.
> >
> > So in summary
> >
> >   - libvirt 0.6.1 has been unpushed from F9 and F10 updates-testing
> >
> >   - The latest version available in F9 and F10 updates is 0.5.1
> >   
> 
> So the updates-testing stuff is just teasers and is never going to be 
> generally available without a full update? And if some of our machines 
> are on one version and some are on another we live with that, roll our 
> own from FC11 source, or force downgrade?

I'm not sure I fully understand the question, but essentially
updates-testing was being used to give a preview of newer releases of
libvirt which weren't intended to be pushed to stable updates. We've
decided that's a bad idea and removed libvirt from updates-testing.

If you've a machine running 0.6.1 from updates-testing, it would
probably be best to downgrade to 0.6.1. Or, indeed, upgrade to F11.

Cheers,
Mark.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]