[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[fedora-virt] Fedora11-Preview without GRUB



Hello,

  after my rawhide installation was corrupted, I planned to install a fresh
Fedora11-Preview in virt-manager. Everything worked well, just GRUB has been
not installed. I can't fix this by running some commands in rescue mode.
My attempts are here:

sh-4.0# df /boot
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/vda1               198337     13573    174524   8% /boot

My root partition is /dev/vda1, so my root disk is /dev/vda (paravirtualized
disk).

sh-4.0# grub-install /dev/vda
expr: non-numeric argument
/dev/vda1 does not have any corresponding BIOS drive.
sh-4.0# grub-install --recheck /dev/vda
Probing devices to guess BIOS drives. This may take a long time.
No suitable drive was found in the generated device map.
Reverting to backed up copy.
sh-4.0# 

grub-install always fails. Trying grub:

sh-4.0# cat /boot/grub/device.map 
# this device map was generated by anaconda
(hd0)     /dev/vda
sh-4.0# grub
Probing devices to guess BIOS drives. This may take a long time.


    GNU GRUB  version 0.97  (640K lower / 3072K upper memory)

 [ Minimal BASH-like line editing is supported.  For the first word, TAB
   lists possible command completions.  Anywhere else TAB lists the possible
   completions of a device/filename.]
grub> setup (hd0)
setup (hd0)

Error 12: Invalid device requested
grub> 

Always no effect. No I don't know, where is my problem. May be this was a
problem of my new virt-manager-0.7, which added some incompatible
parameters. My installed packages (for host system):

[ondrejj work ~]$ rpm -qa \*virt\* gtk-vnc qemu\* \*kvm\* | sort
etherboot-roms-kvm-5.4.4-13.fc11.noarch
etherboot-zroms-kvm-5.4.4-13.fc11.noarch
gtk-vnc-0.3.8-8.fc11.i586
libvirt-python-0.6.1-1.fc10.i386
libvirt-0.6.1-1.fc10.i386
python-virtinst-0.400.3-3.fc10.noarch
python-virtualenv-1.3.2-1.fc10.noarch
qemu-common-0.10-12.fc11.i586
qemu-img-0.10-12.fc11.i586
qemu-system-arm-0.10-12.fc11.i586
qemu-system-cris-0.10-12.fc11.i586
qemu-system-mips-0.10-12.fc11.i586
qemu-system-m68k-0.10-12.fc11.i586
qemu-system-ppc-0.10-12.fc11.i586
qemu-system-sh4-0.10-12.fc11.i586
qemu-system-sparc-0.10-12.fc11.i586
qemu-system-x86-0.10-12.fc11.i586
qemu-user-0.10-12.fc11.i586
qemu-0.10-12.fc11.i586
virt-df-2.1.5-1.fc10.i386
virt-manager-0.7.0-4.fc10.i386
virt-mem-0.2.9-6.fc10.i386
virt-top-1.0.3-2.fc10.i386
virt-viewer-0.0.3-3.fc10.i386

Any ideas, what happened and if it's an error, how to report this?

		SAL


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]