[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [fedora-virt] Fedora11-Preview without GRUB



Hi,

On Wed, 2009-04-29 at 11:58 +0200, Ján ONDREJ (SAL) wrote:
> Hello,
> 
>   after my rawhide installation was corrupted, I planned to install a fresh
> Fedora11-Preview in virt-manager. Everything worked well, just GRUB has been
> not installed.

I think the cause of this was actually a generic grub/anaconda issue -
I'm sure I've seen other reports of grub failing with F11 virt preview.
I think it's been known to hang in the "installing bootloader" installer
step? I can't find any references now, anyone else seen it?

>  I can't fix this by running some commands in rescue mode.
> My attempts are here:
> 
> sh-4.0# df /boot
> Filesystem           1K-blocks      Used Available Use% Mounted on
> /dev/vda1               198337     13573    174524   8% /boot
> 
> My root partition is /dev/vda1, so my root disk is /dev/vda (paravirtualized
> disk).
> 
> sh-4.0# grub-install /dev/vda
> expr: non-numeric argument
> /dev/vda1 does not have any corresponding BIOS drive.

With the fix (i.e. grub-0.97-50.fc11) for:

  https://bugzilla.redhat.com/479760

the following works for me:

  $> grub-install /dev/vda1

with "(hd0) /dev/vda" in /boot/grub/device.map

> grub-install always fails. Trying grub:
> 
> sh-4.0# cat /boot/grub/device.map 
> # this device map was generated by anaconda
> (hd0)     /dev/vda
> sh-4.0# grub

you need to actually pass it the device map:

  $> grub --device-map=/boot/grub/device.map
  grub> root (hd0,0)
  setup --prefix=/grub (hd0)

Cheers,
Mark.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]